BIOS Setup 1.1

Введение

Полный сборник описаний опций BIOS Setup'а, собранный из разных источников. Сборник оформлен в виде одного CHM-файла, что обеспечивает компактность хранения и встроенный поиск по тексту.

О всех неточностях, ошибках большая просьба сообщать по адресу <ryo-oh-ki@narod.ru>. Сюда же обращаться, если нашли интересные сведения (статьи, линки, файлы) по данной теме.

История

  • 26.10.2001 - версия 1.1. Исправления и дополнения (+ 14 новых опций), переформатированы все статьи.
  • 18.09.2001 - версия 1.0. Первый выпуск.

Авторы

  • Николай Распопов (инженер-программист)
    mail: <ryo-oh-ki@narod.ru>
    fido: 2.5015/126.30
    homepage: http://raspopov.dem.ru/
  • Денис Матвиец (школьник)
  • Павел Храпунов (школьник)

Как это делалось?

Денис Матвиец: Все началось каким-то там днем, когда я пришел к моему другу Николаю Распопову. Не помню уже цель визита, но слово за слово, и вот, Николай объясняет мне суть работы (работа сейчас перед вами). Целые каникулы ушли на этот маразм! ;-) Надеюсь вам этот Help будет полезен! Кстати часть работы я переадресовал моему однокласснику Павлу Храпунову, а в HTML он не силён, так что извиняйте коли что не так!

Николай Распопов: Господи, как трудно заставить этих школьников сделать что-нибудь путное! :-)

Источники

  1. Сергей Блохнин <spline@glas.apc.org>
  2. Виталий Якусевич
  3. fido7.su.hardw.chainik
  4. http://www.istc.kiev.ua/~santana/
  5. http://tech.stolica.ru/mb/bios1/
  6. http://hom.com.ua/hardware/library/mb/iXBT_Setup_BIOS.htm
26 октября 2001 года


16 Bit ISA I/O Command WS

Данная опция используется для компенсации возможной разницы между скоростью работы системных устройств ПК и его периферии. Подобная компенсация необходима, например, если в системе не выделено дополнительное время ожидания/ответа устройства. В таком случае система может решить, что какое-либо неуспевающее ответить устройство вообще не функционирует и перестанет давать запросы на ввод/вывод из этого устройства. Данную опцию необходимо отключать ("Disabled") для повышения быстродействия только в случае, когда все устройства в таком режиме нормально функционируют, в противном случае возможна потеря данных. Естественно отключение опции при отсутствии в системе ISA-карт расширения.

Опция может называться "ISA 16-bit I/O Wait States". При этом появляется возможность установить количество тактов ожидания вручную:

  • 0
  • 1
  • 2
  • 3

Ссылки

BIOS

28 июля 2001 года


16 Bit ISA Mem Command WS

Данная опция по назначению аналогична предыдущей, с той лишь разницей, что она позволяет нужным образом соотнести скорость работы памяти ISA-устройства с возможностью системы записывать/читать из этой памяти. Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Опция может называться "ISA 16-bit Mem Wait States". При этом появляется возможность установить количество тактов ожидания вручную: 0, 1, 2, 3.

Ссылки

BIOS

28 июля 2001 года


ACPI Function

Функционирование ACPI. Разрешается или запрещается поддержка через BIOS стандарта ACPI. Включение этой функции имеет смысл, если только операционная система поддерживает ACPI. Если опция включена, система будет игнорировать установки полей "Suspend Mode", "HDD Power Down" и некоторых аналогичных, поскольку уже операционная система ("Windows 98" и выше) возьмет на себя решение многих вопросов. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено (по умолчанию)

Ссылки

BIOS

28 июля 2001 года


ACPI Suspend Type

Возможные значения:

  • "S1(POS)" - включение функции "Power On Suspend"
  • "S3(STR)" - включение функции "Suspend to RAM"

Современные материнские платы все чаще поддерживают режим "Suspend to RAM". При активации этого режима посредством интерфейса ACPI в "Windows 98" (или выше) компьютер полностью выключается, а питание сохраняется лишь для модулей памяти, куда и записывается информация о состоянии системы. После выхода из режима "STR" (путем нажатия клавиши на клавиатуре, по сигналу от модема, т.п.) состояние ПК, в том числе ОС и всех прикладных программ, восстанавливается.

Небольшая рекомендация! Для включения функции ACPI в процессе инсталляции "Windows 98" необходимо добавить следующие параметры в командную строку: setup.exe /pj.

Ссылки

BIOS

28 июля 2001 года


AC PWR Loss Restart

Рестарт после пропадания питания. Разрешение этого параметра позволяет системе включиться автоматически после пропадания питания. В противном случае после восстановления питания система не включится, и необходимо будет снова нажать кнопку подачи питания (Power). Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

28 июля 2001 года


AGP

Смысл этой опции интуитивно понятен, а возможных параметров всего два:

  • "Enabled" (разрешено)
  • "Disabled" (запрещено)

Ссылки

BIOS

28 июля 2001 года


AGP -2x Mode

По умолчанию устанавливается "Disabled". "Enabled" выбирается лишь в случае, если графическая карта поддерживает режим AGP 2x.

Ссылки

BIOS

26 июля 2001 года


Above 1 MB Memory Test

При выборе опции "Enabled" в процессе тестирования ОЗУ проверяется область памяти свыше 1 Мб (область памяти XMS - Extended Memory Specification). На это расходуется дополнительное время в процессе загрузки, тем более такой тест является излишним, так как драйвер-менеджер памяти HIMEM.SYS сам осуществляет проверку оперативной памяти и предпочтительнее использовать именно этот тест, так как он работает в реальном рабочем окружении.

Ссылки

BIOS

26 июля 2001 года


Арбитраж, Bus-Master

Bus Master (хозяин шины, задатчик) - возможный режим работы устройства на любой шине, в том числе и на PCI. Для работы в таком режиме устройство выдает запрос арбитру шины, сообщая о своем требовании на получение управления шиной. Арбитр, в соответствии с приоритетом и/или очередностью арбитража на данной шине, через определенное время после запроса отдает запрашивающему устройству управление шиной. Выполнив все необходимые ему операции, устройство сообщает арбитру об освобождении им шины.

На современных шинах, таких как PCI, для получения доступа к шине ВСЕ устройства проходят процедуру арбитража, в том числе и центральный процессор. Возможность быть "master"-устройством реализуется аппаратно при разработке устройства. Реализация механизма "BusMaster" позволяет общаться между собой только тем компонентам компьютера, которым это в данный момент необходимо. Этот механизм используется, например, для передачи данных TV-тюнером на видеокарту, если они обе находятся на PCI-шине, причем без участия центрального процессора, системной памяти и т.п.

Обычно, система управляет доступом к PCI-шине по фундаментальному принципу - "First-Come-First-Served" (первым пришел, первым обслуживается). Но возможности арбитража значительно шире и сложнее. Существуют и различные режимы действия самого механизма арбитража. Может быть установлен т.н. режим ротации устройств, при котором периодично меняется очередность устройств, т.е. их приоритет. Приоритет может оказаться фиксированным, т.е. какое-либо системное устройство "навсегда" получает наивысший приоритет. При "вращении приоритетов" (rotated) устройству, получившему контроль над шиной, присваивается самый низкий приоритет и любое другое устройство перемещается на шаг вверх в "очереди" приоритетов.

Как же все это реализуется? В состав чипсета входит 8-разрядный ARBITRATION CONTROL REGISTER, позволяющий реализовать свойства, связанные с арбитражем на PCI-шине, а также (у достаточно новых чипсетов) с поддержкой спецификации шины PCI 2.1. (см. ниже)

В современных системах механизмы арбитража, можно сказать, интеллектуализированы, что в итоге привело к изъятию из "BIOS Setup" функций, связанных с пользовательскими установками по арбитражу. "Старые" же версии BIOS вполне могут содержать некоторые из приведенных ниже опций, могущих вызвать душевный трепет у пользователя.

Ссылки

BIOS

26 июля 2001 года


Auto Configuration

Опция автоматического конфигурирования параметров доступа к основной памяти. Опция обычно находится в разделах "Advanced Chipset Setup" или "Chipset Features Setup" и позволяет настроить время доступа к модулям памяти в автоматическом режиме либо в "ручном" режиме и в соответствии со спецификациями применяемых модулей памяти. Чтобы выйти на режим пользовательской настройки, достаточно установить параметр в "Disabled". Значение "Auto" (автоматическая конфигурация) устанавливается по умолчанию.

Среди возможных фиксированных значений обычно встречаются значения "60 ns" и "70 ns" для модулей памяти с соответствующим быстродействием в наносекундах. Опция может называться также "DRAM Auto Configuration" или "Auto Configure EDO DRAM Tim" ("tim" - это timing). В последней опции параметр "Enabled" заменил "Auto", в остальном отличий нет.

Значительно большие различия оказываются в том случае, когда под опцией "Auto Configuration" "скрывается" настройка параметров доброй половины соответствующего раздела "BIOS Setup". Тогда автоматически конфигурируются параметры кэш-памяти, основной памяти, регенерации и даже скорость ISA-шины. Практически все они будут нами изучены.

Ссылки

BIOS

26 июля 2001 года


BIOS Update

Обновление BIOS. Процессоры семейства P6 (Pentium Pro, Pentium II, Celeron, Xeon) имеют особый механизм, называемый "программируемым микрокодом", который позволяет исправить некоторые виды ошибок, допущенных при разработке и/или изготовлении процессоров, за счет изменения микрокода. Обновления микрокода остаются в BIOS и загружаются в процессор в процессе выполнения инструкций BIOS. Именно поэтому BIOS для материнских плат с указанными выше процессорами необходимо регулярно обновлять. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

В "AMI BIOS" была встречена аналогичная опция под названием "CPU MicroCode Updation". Опция может называться и "Pentium II Microcode".

Ссылки

BIOS

26 июля 2001 года


Boot

При включении ПК автоматически запускается находящаяся в BIOS программа загрузки BOOT-ROUTINE. Эта программа вызывает подпрограмму самопроверки POST (Power-On Self Test), проверяющую оперативную память, процессор, жесткий диск и т.д. Далее программа загрузки разыскивает другие BIOS-чипы, которые могут быть встроены, к примеру, в платы расширения. SCSI- контроллеры при этом будут запускать свои собственные тестовые программы.

После этого BIOS берется уже конкретно за платы расширения и расстановку и проверку распределения ресурсов (IRQ, DMA, I/O).

Далее с загрузочных секторов жесткого диска в дело вступает начальный загрузчик, BOOTSTRAP LOADER, - программа, знающая файловую структуру носителя данных. Начальный загрузчик вызывает загрузку загрузочных программ операционной системы.

Этот стандартный алгоритм значительно дополнился и модернизировался с внедрением PnP-технологии и новой PCI-шины, а позже с появлением операционных систем, разработанных с учетом внедрения новейших технологий. Но более подробно об этом будет сказано ниже.

Ссылки

BIOS

26 июля 2001 года


Boot From LAN First

При установке в "Enabled" BIOS предпримет попытку первоначальной загрузки из сетевого загрузочного модуля, прежде чем пытаться загрузиться с локального носителя.

Ссылки

BIOS

26 июля 2001 года


Boot Sequence

Последовательность начальной загрузки системы. Определяется последовательность опроса накопителей для загрузки операционной системы. Эти устройства обозначаются либо буквами для физических жестких дисков и обычных дисководов, либо названием устройства, например "CDROM" для накопителей CD-ROM. Поддерживаются устройства LS-120, Iomega ZIP, ATAPI CD-ROM, IDE- и SCSI-диски. Может принимать значения:

  • "A,C" - такой выбор оправдан только для случая загрузки с дискеты и встречается в старых моделях ПК
  • "A,C,SCSI"
  • "C only"
  • "C,A"
  • "C,A,SCSI"
  • "C,CDROM,A"
  • "CDROM,C,A"
  • "D,A,SCSI" (предназначено при использовании минимум двух IDE-жестких дисков)
  • "E,A,SCSI" (аналогично для 3-х дисков)
  • "F,A,SCSI" (аналогично для 4-х дисков)
  • "LS/ZIP,C"
  • "SCSI,A,C"
  • "SCSI,C,A"

В некоторых версиях BIOS опция "Boot Sequence" трансформировалась в несколько самостоятельных опций, естественно с большей возможностью отбора и большей гибкостью. Это выглядит следующим образом:

  • "First Boot Device"
  • "Second Boot Device"
  • "Third Boot Device"
  • "Boot Other Device"

Параметры могут принимать следующие значения:

  • "Floppy"
  • "HDD-0"
  • "HDD-1"
  • "HDD-2"
  • "HDD-3"
  • "LAN"
  • "SCSI"
  • "LS/ZIP"
  • "CDROM"
  • "Enable"
  • "Disable"

А один из вариантов "AMI BIOS" содержит те же опции, но со значениями:

  • "Floppy"
  • "Floptical" (RS 120)
  • "CD ROM"
  • "SCSI Device"
  • "Network"
  • "IDE0"
  • "IDE1"
  • "IDE2"

А опция "Try Other Boot Devices" через значение "Yes" дает возможность дополнительного выбора варианта загрузки, если имеющиеся варианты не устраивают пользователя. Другое название опции - "System Boot Sequence".

Ссылки

BIOS

26 июля 2001 года


Boot Up Floppy Seek

Поиск дисковода при загрузке компьютера. Так можно перевести название этой функции. Но смысл функции значительно шире, поскольку BIOS проверяет, есть ли дисковод для дискет и идет ли речь при этом о 40- или 80-тидорожечном дисководе. При этом обеспечивается проверка работоспособности дисководов гибких дисков. Поскольку все современные дисководы имеют 80 дорожек (с 1993 года дисководы на 40 дорожек не выпускаются. Они поддерживали формат в 360 КБ), то эта функция необязательна.

Необходимо заметить, что BIOS не может определить разницу между 720K, 1.2M, 1.44M или 2.88M типами дисководов, т.к. все они имеют 80 дорожек. Имеет смысл установить эту опцию в "Disabled" (иначе - "Enabled"), что позволит сократить общее время тестирования ПК после включения.

Ссылки

BIOS

28 октября 2000 года


Boot Up Numlock Status

Опция, определяющая, в каком режиме после включения компьютера должна работать дополнительная цифровая клавиатура. Разрешение этого параметра включает индикатор "Num Lock", и цифровая клавиатура генерирует коды цифр и знаков, в противном случае генерируются коды стрелок, "Ins", "Del" и т.д. Может принимать значения:

  • "On" (иногда "Enabled") - включено
  • "Off" (иногда "Disabled") - отключено

Другое название опции - "System Boot Up Numlock Status". Режим работы в любой момент времени меняется кнопкой NumLock.

Ссылки

BIOS

26 июля 2001 года


Boot Up System Speed

Опция выбора тактовой частоты процессора при загрузке. Значение "Low" переводит процессор в режим работы с половинной тактовой частотой и без использования внутренней кэш-памяти. Естественно, что изначально понижается пропускная способность системной шины. Такой режим может потребоваться при работе со старыми программами или платами расширения, а также при возможных проблемах при запуске системы. По умолчанию всегда устанавливается значение "High". Опция может носить название "System Boot Up CPU Speed".

Ссылки

BIOS

26 июля 2001 года


Boot Virus Detection

Определение вируса в загрузочном секторе. Смысл этого параметра отличается от "Virus Warning" и заключается он в следующем. Если этот параметр запрещен ("Disabled"), то до загрузки операционной системы BIOS переписывает загрузочный сектор во флэш-память и сохраняет его там. Но при этом никаких последствий для системы и пользователя не возникает. При установке параметра в "Enabled" BIOS не будет загружать систему с жесткого диска, если содержимое boot-сектора будет отличаться от сохраненного в памяти. При этом система выводит сообщение, и пользователю, далее, предоставляется возможность либо загрузить систему с жесткого диска, либо с дискеты. Опция может носить название "BootSector Virus Detection".

Ссылки

BIOS

26 июля 2001 года


Burst Refresh

При разрешении этой установки чипсет проводит несколько регенераций за один такт. В обычном режиме одна строка регенерируется каждые 15 мкс, в пакетном 4 строки - каждые 60 мкс. Если BIOS позволяет, то рекомендуется конечно установить значение опции в "Enabled". Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Опция может называться "DRAM Burst at 4 Refresh".

Ссылки

BIOS

12 июля 2001 года


Bus Mastering

Эта опция предназначалась еще не так давно для разрешения или запрещения работы устройств в режиме "Bus-Master" на шине ISA. Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

26 июля 2001 года


Burst Refresh

Метод регенерации памяти, когда сигнал CAS устанавливается раньше сигнала RAS. В отличие от стандартного способа регенерации, этот метод не требует перебора адресов строк извне микросхем памяти - используется внутренний счетчик адресов. Однако, этот способ регенерации должен поддерживаться микросхемами памяти (большинство чипов его поддерживает). Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

12 июля 2001 года


CAS# Latency

Задержка CAS - CL. Важнейшая характеристика чипа памяти, определяющая минимальное количество циклов тактового сигнала от момента запроса данных сигналом CAS (фактически - команда чтения) до их появления и устойчивого считывания с выводов модуля памяти. Возможные значения параметров:

  • 2
  • 3

или в тактах:

  • 2T
  • 3T (3 Clks)

Значение в 3 такта устанавливается по умолчанию. Уменьшение параметра нужно осуществлять крайне осторожно.

Другое название опции - "CAS# Latency Clocks".

Столь важная характеристика памяти сохранила свою "важность" и с внедрением памяти типа SDRAM, а опция стала называться "SDRAM CAS# Latency" (или реже "SDRAM CAS Latency Time").

Отметим, что меньшее значение увеличивает производительность системы (установка в 2 такта в сравнении с 3-мя ускоряет систему на 1-2%). Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 нс или лучше.

Ссылки

BIOS

26 июля 2001 года


Burst Refresh

Действие этой опции возможно при включенном состоянии предыдущей (или аналогичной), так как в данном случае устанавливается время задержки между стробирующими сигналами (в тактах системной шины). Естественно, что установка меньшего значения приводит к снижению времени, затрачиваемого на регенерацию. Большее же значение повышает надежность, т.е. достоверность данных, находящихся в памяти. Оптимальный вариант для данной системы выбирается опытным путем. Может принимать значения:

  • 1T
  • 2T (по умолчанию)

Ссылки

BIOS

12 июля 2001 года


CPU Critical Temperature

Возможные варианты:

  • Disabled
  • 45 °C
  • 50 °C
  • 55 °C
  • 60 °C
  • 65 °C
  • 70 °C
  • 75 °C

Ссылки

BIOS

28 июля 2001 года


CPU External Cache

Разрешается/запрещается внешний кэш процессора. Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Ссылки

BIOS

28 октября 2000 года


CPU Fast String

Быстрые операции со строками. Разрешение этого параметра позволяет использовать некоторые специфические особенности архитектуры семейства Pentium Pro (Pentium II, Deshutes и т.п.), в частности, возможность кэширования операций со строками. Hадо только понимать, что и в самой программе должны быть выполнены условия для включения этого механизма. Эти условия указаны в документации на любой процессор данного семейства. Параметр рекомендуется оставлять в состоянии "Разрешено".

Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

3 сентября 2001 года


CPU Internal Cache

Разрешается/запрещается внутренний кэш процессора. Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Ссылки

BIOS

28 октября 2000 года


CPU Level 1 Cache

Разрешается/запрещается кэш первого уровня для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Ссылки

BIOS

28 октября 2000 года


CPU Level 2 Cache

Разрешается/запрещается кэш второго уровня для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Запрещать какой-либо вид кэш-памяти следует только в случае необходимости искусственно замедлить работу компьютера, например, при установке какой либо старой платы расширения.

Ссылки

BIOS

28 октября 2000 года


CPU Level 2 Cache ECC Check

Опция включения/отключения коррекции ошибок кэша второго уровня у процессоров архитектуры Pentium II и выше, которые поддерживают эту опцию. К примеру, процессоры Pentium II поддерживает коррекцию ошибок, начиная с частоты в 333 МГц. ECC-коррекция несомненно повышает надежность системы, но при этом ее работа, как правило, несколько замедляется. В некоторых процессорах допущены ошибки, и включение этого режима может привести к нестабильной работе системы. К тому же фактор надежности играет значительную роль только в сетевых средах. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Чуть другие названия этой же опции: "CPU Level 2 ECC checking" и "CPU L2 Cache ECC Checking".

Ссылки

BIOS

12 июля 2001 года


CPU Priority

После вышеизложенного содержание этой опции может быть уже и не покажется странным. Пользователь должен установить, по сути, ранг центрального процессора в иерархии всех возможных "master"-устройств в системе. Если для остальных устройств, допустим, может выдерживаться "режим ротации", то для CPU его место всегда окажется фиксированным. Это место можно выбрать из ряда:

  • Always Last
  • CPU 2nd
  • CPU 3rd
  • CPU 4th

Опция с тем же названием была встречена и с обычными "Disabled" и "Enabled". Можно предположить, что "Disabled" запрещает ротацию приоритета для CPU, а "Enabled" ее разрешает. Ну и наконец, опция "PCI Masters' Priority" предлагает на выбор: "Rotating" и "Fixed".

Ссылки

BIOS

26 июля 2001 года


CPU to DRAM Page Mode

Когда опция установлена в "Disabled", контроллер памяти закрывает страницу памяти после доступа к ней. Когда опция включена (по умолчанию), страница памяти остается открытой на случай повторного обращения к ней. Такой режим работы памяти более производителен.

Этот же смысл характерен для множества функций с подобными наименованиями: "DRAM Page Mode", "DRAM Paging", "DRAM Paging Mode", "SDRAM Page Control".

Так же широк и выбор возможных значений параметров. В различных версиях BIOS можно даже найти опции с одинаковыми названиями, но различными значениями параметров. Например, "CPU to DRAM Page Mode" может предоставить для выбора значения "Use Paging" и "No Paging". Возможны и следующие вариации: "Always Open" и "Closes", "Page Closes", "Stays Open" и "Closes If Idle", "Normal" и "Disabled".

В некоторых случаях усовершенствованный (enhanced) механизм работы чипсета и контроллера памяти позволяет с помощью дополнительной информации об открытой странице памяти сохранять ее некоторое время открытой даже при отключенной опции: "DRAM Enhanced Paging", "Enhanced Page Mode", "Enhanced Paging".

Ссылки

BIOS

26 июля 2001 года


CPU-to-PCI 6 DW FIFO

Опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 6-х двойных слов (Double Word). Работа с буфером построена по принципу "первым пришел - первым ушел" (First Input - First Output). Естественно, что буферизация передачи информации повышает быстродействие системы, но в таком виде эта опция встречается уже редко.

Ссылки

BIOS

12 июля 2001 года


CPU-to-PCI IDE Posting

Включение данного режима позволяет оптимизировать циклы записи из CPU в интерфейс PCI IDE путем предварительной буферизации. Параметр рекомендуется устанавливать в состояние "Enabled". Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

12 июля 2001 года


CPU-to-PCI Read Buffer

Опция включения/отключения специального буфера, позволяющего устройствам обращаться к PCI-шине и считывать до 4-х двойных слов, не прерывая при этом работу процессора. Процессор может работать в это время над другой задачей, что повышает общую производительность. Эта опция должна быть включена обязательно. В отключенном же состоянии буфер не будет использоваться, и циклы чтения процессора не будут заканчиваться до тех пор, пока шина PCI не подаст сигнал о готовности получить данные.

Ссылки

BIOS

12 июля 2001 года


CPU-to-PCI Write Buffer

Во включенном состоянии опции процессор сможет записывать по 4 слова за один такт в буфер записи шины PCI до завершения цикла PCI-шины. При установке параметра в "Disabled" процессор будет находиться в ожидании после каждого цикла записи и до тех пор, пока шина PCI не сообщит процессору о своей готовности к приему данных. Опция может называться также просто "CPU to PCI Buffer". В этом случае речь идет уже об интегрированной функции с теми же параметрами: включен буфер/отключен буфер.

Ссылки

BIOS

12 июля 2001 года


CPU-to-PCI Write Latency

Определение времени задержки перед операцией записи данных из процессора в шину (в тактах системной шины). Установка меньшего значения позволяет увеличить производительность, однако при этом возможно увеличение нестабильности работы системы. Тогда необходимо будет вернуться к большему значению. Возможный ряд значений:

  • 1T
  • 2T
  • 3T

Опция может называться также "Latency for CPU to PCI write".

Ссылки

BIOS

12 июля 2001 года


Chipset Special Features

Специальные возможности чипсета. Данный параметр разрешает/запрещает все новые функции, появившиеся в 430-х наборах Intel (HX, VX или TX) по сравнению с FX. Если установлено "Disabled", чипсет функционирует как 82430FX. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

12 июля 2001 года


Concurrent Refresh

Паpаллельная регенерация. При активизации этой опции как чипсет (т.е. оборудование, требующее регенерации), так и процессор получают одновременный доступ к памяти. При этом процессору не нужно будет ожидать, пока произойдет регенерация. При установке опции в "Disabled" процессор должен будет ждать, пока схема регенерации не закончит работу.

Ссылки

BIOS

12 июля 2001 года


DMA

Direct Memory Access - "прямой доступ к памяти". Он осуществляется через DMA-контроллер - специальный чип, получающий первоначальную команду на перенос данных от центрального процессора. Каналы DMA предназначены для передачи массивов информации по 8- или 16-битным шинам одновременно. В отличие от портов ввода/вывода каналы DMA непосредственно не сообщаются с центральным процессором, они работают напрямую с системной памятью. Всего каналов DMA - 8 (от 0 до 7).

Первоначально DMA-контроллер задумывался, прежде всего, для разгрузки CPU от тривиальных задач, например, контроля флоппи- дисководов или жестких дисков. Начиная с компьютеров PC/AT передача данных от жестких дисков и к ним стала осуществляться уже не через каналы DMA, а через программируемый ввод/вывод.

Начиная с Intel 80386, процессоры располагают собственным устройством управления памятью (MMU - Memory Management Unit), которое пересчитывает логические адреса в физические. DMA-контроллеры "ничего не знают" о разрядности адресов. Поэтому, чтобы иметь возможность применять DMA вместе с управлением виртуальной памятью, нужно зарезервировать в качестве DMA-буфера какую-то область памяти в первом мегабайте адресного пространства, где логические и физические адреса совпадают. В эту область DMA-контроллер записывает данные, прежде чем они будут скопированы процессором из этого буфера. Эта технология, называемая двойной буферизацией, неэффективна.

Основными "потребителями" каналов DMA являются звуковые карты, CD-ROM-дисководы более ранних выпусков. В обоих случаях скорость передачи не превышает 500 Кб/с. Максимально возможная скорость передачи данных по DMA-каналам (около 2 Мб/с) значительно перекрывает потребности 8-битной звуковой карты. Если же необходимо осуществить быстрый обмен информацией, то в этом случае DMA не используется - процессор берет на себя управление процессом переноса информации, перекрывая все допустимые способности DMA-каналов.

DMA-канал | Разрядность | Назначение
0 | 8 | свободен (ранее использовался в PC/XT для обновления памяти
1 | 8 | обычно задействуется под звуковые или сетевые карты
2 | 8 | контроллер floppy-дисководов
3 | 8 | свободен (в PC/XT обеспечивал передачу данных от HD), иногда используется EPP-функцией параллельного порта
4 | 16 | каскадирование для 8-разрядного контроллера (координация между "старым" и "новым" чипами DMA)
5 | 16 | свободен (часто задействуется под 16-разрядные звуковые карты)
6 | 16 | свободен
7 | 16 | свободен

Ссылки

BIOS

26 июля 2001 года


DMA n Assigned to

Канал DMA с номером n назначен на... . Каждому каналу DMA системы может быть назначен один из следующих типов устройств:

  • "Legacy ISA" (классические ISA-карты). Это стандартные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки "Plug&Play". Эти карты требуют назначения каналов DMA в соответствии с документацией на них
  • "PCI/ISA PnP" (устройства для шины PCI или устройства для шины ISA с поддержкой Plug&Play).

Ссылки

BIOS

23 июля 2001 года


DMA n Used By ISA

Контроль частоты тактового сигнала контроллера клавиатуры. Параметром задается, проще говоря, скорость, с которой центральный процессор связывается с контроллером клавиатуры. Таким образом, параметр служит для изменения скоростных характеристик работы клавиатуры и повышения стабильности ее работы. Значение параметра как "12 MHz" устанавливается по умолчанию. Если возникли проблемы при работе с клавиатурой, необходимо уменьшить значение параметра. Параметр может принимать значения: "8 MHz", "12 MHz", "16 MHz".

Опция также может носить названия: "KBC Input Clock Select", "Кeyboard Controller Clock".

В общем-то, это уже устаревшая функция, позволявшая в соответствии со спецификациями инсталлированного контроллера клавиатуры устанавливать либо фиксированные значения, например, 7.16 МГц, 9.5 МГц, другие значения, либо получать значения как частное от частоты системной или локальной шины.

Ссылки

BIOS

26 июля 2001 года


Doze Mode

Режим засыпания. Устанавливает время перехода или запрещает переход в первую стадию снижения энергопотребления. Может принимать значения:

  • 30 Sec
  • 1 Min
  • 2 Min
  • 4 Мin
  • 8 Min
  • 20 Min
  • 30 Min
  • 40 Min
  • 1 Hour
  • Disabled

Ссылки

BIOS

3 сентября 2001 года


Doze Speed

Частота процессора в режиме Doze. Определяет коэффициент деления тактовой частоты в режиме Doze (засыпание).

Ссылки

BIOS

3 сентября 2001 года


DRAM Data Integrity Mode

Опция включения/отключения проверки целостности памяти. Включение опции позволит системе отслеживать и корректировать однобитные ошибки. Так же будут обнаруживаться двухбитные ошибки, но без исправления. Использование режима коррекции ошибок обеспечивает увеличение стабильности и целостности данных в системе, правда, при небольшой потере производительности. Если в системе не используются ECC-модули памяти, то опция должна быть отключена. Может принимать значения:

  • "ECC" - разрешена коррекция
  • "Non-ECC" - коррекция запрещена

В некоторых случаях опция с тем же названием может иметь другой "набор" параметров:

  • "Parity"
  • "ECC"

При этом меняется и содержание функции.

Ссылки

BIOS

12 июля 2001 года


DRAM ECC/PARITY Select

Опция выбора режима коррекции ошибок/проверки по четности. Эта опция появляется только в BIOS тех материнских плат, в которых чипсет поддерживает ECC, и может быть использована только в том случае, если установлены модули памяти с истинной четностью. В некоторых вариантах BIOS этим параметром может устанавливаться только вид проверки, а разрешение на проверку устанавливается параметром "Data Integrity (PAR/ECC)" или аналогичным. Параметр может принимать значения:

  • "Parity" (по умолчанию) - в случае возникновения ошибки на монитор выдается сообщение о сбое по четности в памяти и работа компьютера останавливается
  • "ECC" - в случае возникновения одиночной ошибки она исправляется и работа системы продолжается. Если имеет место не одиночная ошибка, то работа компьютера также приостанавливается. Следует только учесть, что, по данным "Intel", скорость обмена с памятью при включении этого режима уменьшается приблизительно на 3%.

Ссылки

BIOS

12 июля 2001 года


DRAM Page Idle Timer

Таймер пассивного состояния страницы памяти. С помощью этой функции устанавливается время (в системных тактах), в течение которого контроллер DRAM, после перехода процессора в режим ожидания, ждет закрытия всех открытых страниц памяти.

Параметр сохранил свою актуальность со времен FPM. Для увеличения быстродействия устанавливается минимальное значение данного параметра, однако при этом возможна нестабильная работа системы. Оптимальный вариант устанавливается опытным путем. Опция может называться "Paging Delay", "DRAM Idle Timer", а возможные значения выбираются из ряда:

  • 1T
  • 2T
  • 4T
  • 8T

Правда, иногда такой ряд может иметь следующий вид:

  • 0
  • 2
  • 4
  • 8
  • 10
  • 12
  • 16
  • 32

Ссылки

BIOS

26 июля 2001 года


DRAM RAS Only Refresh

Включение/отключение метода обновления DRAM, альтернативного методу "CAS-before-RAS". Если BIOS содержит другие возможности по регенерации памяти, то эту опцию необходимо отключить. В противном случае придется использовать этот устаревший метод обновления памяти.

Ссылки

BIOS

12 июля 2001 года


DRAM RAS# Precharge Time

Время предварительного заряда по RAS. Эта функция позволяет установить время (в тактах системной шины) для формирования сигнала RAS (иногда говорят о накоплении заряда по RAS) до начала цикла регенерации памяти. Уменьшение этого значения увеличивает быстродействие. Но если установлено недостаточное время, регенерация может быть некомплектной, что в итоге приведет к потере данных, находящихся в памяти. Возможные значения могут быть представлены в различном виде: в виде цифровых значений - "3", "4" и т.д.; с указанием системных тактов - "3 Clocks" или "1T". А ряд значений, как правило, следующий:

  • 0T
  • 1T
  • 2T
  • 3T
  • 4T
  • 5T
  • 6T

Опция может иметь множество названий:

  • DRAM RAS# Precharge Period
  • RAS# Precharge Time
  • RAS# Precharge Period
  • FPM DRAM RAS# Precharge
  • FPM RAS Precharge
  • RAS# Precharge
  • EDO RAS Precharge
  • EDO RAS# Precharge Time
  • EDO RAS Precharge Timing
  • FPM/EDO RAS# Precharge Time

Как видим, опция не потеряла своей актуальности с появлением EDO-памяти и, что интересно, затем также BEDO- и SDRAM- модулей: "BEDO RAS Precharge", "SDRAM RAS# Precharge", "SDRAM RAS Precharge Time".

Правда, кроме привычных параметров типа "3T" или "2 Clks" в различных версиях BIOS стали "встречаться" новые виды значений, например, "Same as FPM" и "FPM-1T", "Fast" и "Normal", "Fast" и "Slow". Для последней пары параметров "Slow" (медленно) равносильно увеличению количества тактов, что повышает стабильность работы системы, поэтому значение "Fast" следует устанавливать в случае уверенности в качестве модулей памяти.

Ссылки

BIOS

12 июля 2001 года


DRAM Refresh Period

Установка периода (частоты повтора), требуемого для регенерации памяти, в соответствии со спецификацией модулей памяти. В новейших версиях BIOS такая опция практически не встречается. Ранее же она предлагала пользователю широкий простор для творчества: в зависимости от версии BIOS и его производителя, чипсета, модулей памяти. Опция могла также носить название "Refresh Cycle Time (us)", "DRAM Refresh Cycle Time", "Memory Refresh Rate" или "DRAM Refresh Rate".

Вот неполный перечень таких вариаций: "For 50 MHz Bus", "For 60 MHz Bus", "For 66 MHz Bus" и даже "Disabled", "50/66 MHz", "60/60 MHz", "66/66 MHz", "Disabled", "15.6 us", "31.2 us", "62.4 us", "124.8 us", "249.6 us", "15.6 us", "31.2 us", "62.4 us", "125 us", "250 us", "15.6 us", "62.4 us", "124.8 us", "187.2 us", "1040 Clocks", "1300 Clocks", "Disabled", "Normal", "Fast", "Slow".

Остается отметить, что чем реже производится регенерация памяти, тем эффективнее работает система. Но если явно наблюдаются нарушения в работе системы, то частоту обновления необходимо повысить.

Ссылки

BIOS

26 июля 2001 года


Data Integrity (PAR/ECC)

Целостность данных. Опция разрешения/запрещения контроля памяти на ошибки. Вид контроля устанавливается параметром "DRAM ECC/PARITY SELECT". Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

12 июля 2001 года


Daylight Saving

Во включенном состоянии ("Enabled") эта опция позволяет автоматически добавлять или вычитать один час при весеннем или осеннем переводе времени (последнее воскресенье апреля и аналогично в октябре). Этот параметр можно отключить, если установлена "Windows 9x", самостоятельно регулирующая этот процесс.

Ссылки

BIOS

26 июля 2001 года


Delay IDE Initial

Задержка инициализации IDE-устройства. В данном параметре устанавливается интервал времени (в секундах), в течение которого IDE-устройство не будет опрашиваться BIOS после включения питания. Ненулевое значение параметра рекомендуется устанавливать только в случае применения старых жестких дисков. Не все старые приводы способны достичь номинальной скорости вращения за время, которое при включении ПК проходит до начала тестирования жесткого диска. Опция была введена первоначально в "AMI BIOS" для использования старых накопителей и позднее была оставлена для совместимости.

В различных версиях BIOS могут встретиться абсолютно идентичные функции: "Hard Disk Pre-Delay", "Delay For HDD (Secs)". Хотя при этом могут несколько варьироваться значения параметров: от "0" до "15", от "0" до "30", от "1" до "15" и "Disabled".

Ссылки

BIOS

26 июля 2001 года


DRAM Idle Timer

Таймер пассивного состояния памяти. Этим параметром устанавливается время (в тактах) до закрытия всех открытых страниц памяти. Влияет как на EDO так и на SDRAM память. Может принимать значения:

  • 0
  • 2
  • 4
  • 8
  • 10
  • 12
  • 16
  • 32

Ссылки

BIOS

28 июля 2001 года


Delayed Transaction

Специальные возможности чипсета - задержанная транзакция на PCI. Присутствие этого параметра в BIOS означает, что на материнской плате есть встроенный 32-битный буфер с задержанной записью для поддержки удлиненного цикла обмена на PCI-шине. Если этот параметр разрешен, то доступ к шине PCI разрешен во время доступа к 8-разрядным устройствам на шине ISA. Это существенно увеличивает производительность системы, так как цикл такого обращения на ISA-шине занимает 50-60 тактов шины PCI. Если компьютер укомплектован материнской платой, не поддерживающей спецификацию PCI 2.1, этот параметр следует запретить, поскольку данная опция включает режим совместимости со спецификацией PCI версии 2.1 с одновременным включением в "северном" мосте упомянутого выше специального буфера. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Опция может называться также "PCI Delayed Transaction", "Delayed Transaction Optimization" или "Delayed Transaction Timer" с теми же значениями (включено/отключено).

Ссылки

BIOS

12 июля 2001 года


Deturbo Mode

Режим deturbo. При разрешении этого параметра сигнал FLUSH# становится активным и никакие данные после этого не кэшируются процессором в свой внутренний кэш (кэш первого уровня) процессорами архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). Разрешение этого параметра следует использовать только при необходимости сознательно замедлить работу компьютера.

Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

28 июля 2001 года


Drive NA before BRDY

Когда выбрано "Enabled", сигнал NA (читай ниже) устанавливается на один такт раньше последнего сигнала BRDY# в каждом цикле чтения/записи, таким образом вызывая генерацию процессором сигнала ADS# в следующем цикле после BRDY#, устраняя один потерянный цикл. С помощью сигнала BRDY# (Bus Ready) чипсет (точнее, т.н. "северный мост") сообщает процессору о том, что данные доступны для чтения или есть готовность для приема данных для их записи.

Ссылки

BIOS

12 июля 2001 года


ECP DMA Select

Выбор канала DMA для режима ECP. Параметр появляется только при разрешении режима ECP или ECP+EPP в Parallel Port Mode (ECP+EPP). Для нормальной поддержки режима ECP требуется задействовать канал DMA, который выбирается из каналов 1 или 3.

Может принимать значения:

  • 1 - канал 1
  • 3 - канал 3
  • Disabled - запрещено использовать DMA

Ссылки

BIOS

3 сентября 2001 года


Enable Master

Установка в "Enabled" позволяет системе придать выбранному устройству статус "master"-устройства на PCI-шине, а также проверить, способно ли это устройство контролировать шину.

Ссылки

BIOS

26 июля 2001 года


Expansion Board not ready at Slot X

BIOS не может найти плату в слоте номер X. Проверить установку платы в этом слоте.

Ссылки

BIOS

26 июля 2001 года


Extended ROM RAM Area

Наличие этой опции характерно для старых версий "AMI BIOS". Пользователю предоставляется выбор, где хранить данные о жестком диске: в верхнем килобайте системной памяти, начиная с 639-го килобайта, или в адресах нижней памяти в области системного BIOS (0:300). Необходимо помнить, что вторая адресная область может также использоваться звуковыми, сетевыми и т.п. картами расширения. В этом случае конфликтов можно избежать, если система через BIOS может использовать механизмы "затенения", которые впрочем могут отсутствовать в очень старых системах.

Опция может называться и "RAM Area".

Ссылки

BIOS

12 июля 2001 года


Extended Refresh

Расширенная регенерация. Введение (в свое время) этой опции в BIOS предполагало использование специальных EDO-чипов. Регенерация содержимого ячеек EDO DRAM при этом стала производиться через 125 мкс, а не через каждые 15,6 мкс, как при стандартной регенерации. Это несколько повысило общее быстродействие памяти.

Ссылки

BIOS

12 июля 2001 года


Flash BIOS Protection

Включение опции запрещает доступ к Flash BIOS вирусам и неопытным пользователям. При этом не может быть произведено обновление содержимого Flash BIOS. Для обновления функцию надо отключить. На некоторых материнских платах функция реализована не в виде опции "BIOS Setup", а в виде перемычки, либо не реализована вовсе. Желательно функцию включить. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

26 июля 2001 года


Floppy Disk Access Control (R/W)

Функция может находиться в меню "BIOS FEATURES SETUP" и определять возможность чтения/записи на дискеты. Включение опции как "Read only" позволит защитить информацию от несанкционированного копирования. Некоторые BIOS в качестве значений параметра имеют обычные "Enabled" и "Disabled". В этом случае разрешение этого параметра позволяет записывать информацию на дискету, а в противном случае дискету можно только читать.

Ссылки

BIOS

24 июля 2001 года


Gate A20 Option

Вариант включения линии A20. Параметр позволяет управлять способом включения адресной линии A20, которая отвечает за доступ к памяти, физические адреса которой превышают 1 Мбайт. Стоит напомнить, что 20-разрядная адресная шина позволяет адресоваться в пределах первого мегабайта памяти. Если быть более точным, то эта линия отвечает за доступ к первым 64 килобайтам верхней памяти, известным как область HMA (High Memory Area).

Доступ к HMA требует управления специальным аппаратным узлом, работа которого может быть блокирована или активизирована. При установке опции "Gate A20 Option" в состояние "FAST" работа линии как раз и будет контролироваться специальным набором микросхем на системной плате. Если линия А20 деблокирована, то HMA-область доступна для любой программы, работающей в реальном режиме. Обычно эта область памяти отдается под MS-DOS, а для деблокирования линии используется драйвер HIMEM.SYS.

На старых машинах контролем A20 занимался контроллер клавиатуры, теперь это переложено на системную логику. Но есть категория пользователей, использующих старое программное обеспечение. Для таких и предназначена эта опция. Это означает, что наличие такой опции связано с совместимостью со старым ПО. Необходимо также отметить, что некоторые драйверы MS-DOS, например VDISK.SYS, могут блокировать линию А20, входя в конфликт с драйвером HIMEM.SYS.

С другой стороны установка опции в "FAST" может значительно повысить производительность системы под "OS/2" и "Windows". Может принимать значения:

  • "Fast" - управление осуществляется чипсет, что повышает скорость работы
  • "Normal" - управление осуществляется через контроллер клавиатуры

В некоторых версиях BIOS опция может называться "Fast Gate A20 Option", а параметрами будут стандартные "Enabled"/ "Disabled". Иногда в старых версиях BIOS можно встретить опцию с почти романтическим названием "LOWA20# Select". А речь идет о том, какое устройство управляет низким уровнем сигнала на линии A20: чипсет или контроллер клавиатуры.

Ссылки

BIOS

12 июля 2001 года


Graphics (AGP) Aperture Size

Размер графической апертуры для AGP. Апертурой называется порция адресов памяти PCI, выделенная в адреса графической памяти. Циклы, обращающиеся к этим адресам, не требуют трансляции и передаются напрямую в AGP. Кроме того, размер указывает максимальный объем системной памяти, выделяемый для хранения текстур. Размер апертуры незначительно сказывается на производительности. Но большинство современных адаптеров требует более 8МБ апертуры для нормального функционирования.

Замечено также, что на акселераторах TNT тесты по обработке больших массивов текстур существенно замедлялись в случае выделения менее 64МБ памяти. На текущий момент стандартным размером является значение "64M". Нет смысла увеличивать это число, так как увеличивается размер GART таблицы. Доступный ряд значений графической апертуры:

  • 4M
  • 8M
  • 16M
  • 32M
  • 64M
  • 128M
  • 256M

Ссылки

BIOS

26 июля 2001 года


Halt On

Сразу после включения ПК, во время теста самопроверки POST, при нахождении какой-либо аппаратной ошибки система прекращает загрузку и выводит наименование устройства, вызвавшего сбой. Будет ли произведена остановка, и в каких случаях это произойдет, как раз и определяет параметр команды "Halt On". Возможными параметрами являются:

  • "No Errors" - POST никогда не прерывает работу, какая бы не фатальная для системы ошибка не была обнаружена (нарушение работы устройства или даже его отсутствие)
  • "All Errors" - остановка работы при возникновении любой критической, но не фатальной, ошибки
  • "All, But Keyboard" - остановка при любой критической ошибке, кроме ошибки клавиатуры
  • "All, But Diskette" - аналогично, только с игнорированием ошибок дисководов
  • "All, But Disk/Key" - игнорирование ошибок клавиатуры и дисководов

Опция может носить название "Error Halt".

Ссылки

BIOS

26 июля 2001 года


HDD Power Down

Выключение жесткого диска. Устанавливает либо время, через которое при отсутствии обращения жесткий диск будет выключен, либо запрещает такое выключение вообще. Параметр не оказывает влияние на диски SCSI.

Может принимать значения от 1 до 15 минут, Disabled - запрещено.

Ссылки

BIOS

3 сентября 2001 года


HDD S.M.A.R.T Capability

Возможность S.M.A.R.T диагностики. Позволяет разрешать/запрещать возможность диагностики состояния жесткого диска в соответствии с требованиями стандарта S.M.A.R.T. Авторы BIOS, к сожалению, не раскрывают механизма функционирования S.M.A.R.T диагностики в BIOS, поэтому не совсем понятно, каким образом обрабатывается информация от жесткого диска, так как граничные значения параметров жесткого диска зависят от конкретного производителя. При разрешении параметра и нарушении нормального функционирования жесткого диска BIOS выдает на экран соответствующее сообщение до появления таблицы с характеристиками компьютера. Следует учесть, что разрешение этого параметра снизит производительность компьютера на несколько процентов. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

3 сентября 2001 года


Hi-Speed Refresh

С помощью этой опции чипсет быстрее проведет регенерацию основной памяти. Правда, эффект от этой установки значительно меньше, чем от включения "Slow Refresh". Последний режим регенерации предпочтительнее. К тому же эта функция поддерживается не всеми чипами памяти.

Ссылки

BIOS

12 июля 2001 года


Hidden Refresh

Скpытая регенерация. Когда установлено значение "Disabled", память регенерируется по IBM AT методологии, используя циклы процессора для каждой регенерации. Когда "Hidden Refresh" установлен в "Enabled", контроллер "ищет" наиболее удобный момент для регенерации, независимо от циклов CPU. При этом регенерация происходит одновременно с обычным обращением к памяти. Алгоритм регенерации памяти при этом многовариантен: разрешаются циклы регенерации в банках памяти, не используемых центральным процессором в данный момент, взамен или вместе с нормальными циклами регенерации, выполняемыми всякий раз при определенном прерывании (DRQ0 - каждые 15 мс), вызванном таймером.

Для регенерации каждый раз требуется от 2 до 4 мс. В течение этих 4 мс один цикл регенерации примерно каждые 16 мкс регенерирует по 256 строк памяти. Каждый цикл регенерации занимает столько же или чуть меньше времени, чем один цикл чтения памяти, т.к. сигнал CAS для регенерации при этом не требуется.

"Hidden refresh" отличается максимальной скоростью и эффективностью, наименьшими нарушениями активности системы и наименьшими потерями производительности, также позволяя поддерживать состояние памяти во время нахождения системы в режиме "suspend". Этот режим более быстрый, чем "Burst Refresh". Но наличие в BIOS этой функции еще не означает ее реализации. После установки опции в "Enabled" стоит тщательно проверить работоспособность компьютера. Некотоpые модули памяти позволяют использовать "Hidden Refresh", некоторые - нет. В большинстве случаев рекомендуется установить в "Enabled".

Ссылки

BIOS

12 июля 2001 года


Hit "Del" Message Display

Отключение этой опции не позволит вывести на экран монитора сообщение о том, с помощью какой клавиши возможен доступ к "BIOS Setup" во время загрузки системы. Косвенно эта опция может служить в качестве защитной функции, хотя и весьма сомнительной.

Ссылки

BIOS

28 октября 2000 года


Host Bus Fast Data Ready

Быстрая готовность данных на шине. Разрешение этого параметра позволит снимать данные с шины одновременно с их выборкой. В противном случае данные будут удерживаться на шине один дополнительный такт.

Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

3 сентября 2001 года


IDE PIO Mode

Выбор режима работы каждого диска. Четыре параметра позволяют устанавливать режимы работы каждого диска индивидуально или разрешить BIOS автоматическую установку самого высокоскоростного режима для диска. Для каждого диска допустимые параметры одинаковы. Hапример, для IDE 0 Master Mode допустимые значения:

  • 0
  • 1
  • 2
  • 3
  • 4
  • AUTO

Ссылки

BIOS

3 сентября 2001 года


IR Duplex Mode

Опция для выбора дуплексного или полудуплексного режима работы инфракрасного порта. По умолчанию устанавливается "Half". Другим значением является естественно "Full" (дуплекс). Стоит напомнить, что под дуплексом понимают двунаправленную передачу данных, которая может происходить в двух направлениях в одно и то же время. При полудуплексе передача данных в некий момент времени происходит только в одном направлении.

Эта опция доступна, если функция "UART2 Mode Select" установлена в "HPSIR" или "ASKIR".

В некоторых версиях BIOS аналогичная функция может называться "IR Transfer Mode", а параметры могут звучать как "Half-Duplex" и "Full-Duplex". Опция может называться также "UR2 Duplex Mode", "UART 1/2 Duplex Mode", "Duplex Select", "InfraRed Duplex Type", "IR Function Duplex".

В некоторых случаях в параметрах установки может появиться значение "Disabled", как отказ от использования инфракрасного порта. Присутствие в наименованиях опций конкретного указания на второй последовательный порт может говорить только об одном: соединительный кабель уже опциально подключен ко второму последовательному порту, использование первого последовательного интерфейса в качестве инфракрасного не допускается и т.п.

Ссылки

BIOS

26 июля 2001 года


IRQ

IRQ | Устройство | Приор. | Комментарии
0 | Системный таймер | * 15 | Системное прерывание. Генерируется 91 раз за 5 сек. В данном качестве применяется со времени первого PC.
1 | Клавиатура | * 14 | Системное прерывание, генерируемое контроллером клавиатуры.
2 | Контроллер прерываний | * 13 | Каскадировано (связано) с IRQ9. Могут возникнуть конфликты, когда одновременно на IRQ2 и IRQ9 должны работать различные устройства. Его использование системой сохраняется для совместимости.
3 | COM 2 | 4 | Используется вторым коммуникационным адаптером (UART2). Какое же устройство будет его генерировать? Это может быть второй последовательный порт COM2 (интегрирован на материнской плате), внутренний модем, настроенный на COM2 или COM4, или инфракрасный адаптер. Можно отключить UART2, но присвоить IRQ3 ничему не удастся. Делит одно и то же IRQ3 с COM4 (при наличии последнего). Возможен конфликт при одновременном использовании.
4 | COM 1 | 3 | Используется первым коммуникационным адаптером. Все практически идентично: генерируется первым последовательным портом COM1, модемом на COM1 или COM3 (за исключением инфрапорта). Делит одно и то же IRQ4 с COM3 (при наличии последнего). В системах с подключенной к COM1 мышью использовать COM3 не следует.
5 | свободен | 2 | Прерывание изначально предназначалось для использования вторым параллельным портом LPT2. Практического применения такое решение не нашло, поэтому IRQ5 перешло в разряд свободных. В IBM XT на IRQ5 "висел" жесткий диск. Через некоторое время "Creative Labs", создавая звуковую карту "Sound Blaster Pro", нашла применение прерыванию. С тех пор IRQ5 стало излюбленным для большинства звуковых ISA-карт. Звуковые PCI-карты также иногда используют это прерывание для эмуляции "SB Pro". IRQ5 можно привязать к слоту PCI.
6 | Контроллер FDD-дисковода | * 1 | Прерывание используется контроллером флоппи-дисковода, начиная с первых ПК. Ныне его можно отключить, если перейти на совместимый с обычными дискетами накопитель LS-120 с интерфейсом EIDE. Однако прерывание все равно не может быть использовано: ISA-карты на работу с ним не рассчитаны, и к слоту PCI привязать его нельзя. Может быть использовано для привода на на магнитной ленте.
7 | LPT 1 | 0 | По умолчанию прерывание первого параллельного порта LPT1. При отключенном порте (если принтер отсутствует или рассчитан на USB) может использоваться различными устройствами: сетевыми, ISDN-картами. Это также "запасное" место для звуковых карт.
8 | Часы реального времени (RTC) | * 12 | Системное прерывание со времени первых IBM AT.
9 | свободен | 11 | Каскадировано с IRQ2. В остальном может использоваться по усмотрению.
10 | свободен | 10 | Может быть использовано по усмотрению. Устаревшие IDE-контроллеры на старых звуковых картах иногда используют это IRQ.
11 | свободен | 9 | Может быть использовано по усмотрению, часто используется видеокартами. В современных ПК обычно резервируется для шины USB. При отключении последней в BIOS может быть задействовано иначе.
12 | свободен или PS/2-мышь | 8 | Если используется мышь, это IRQ в большинстве случаев выдается лишь по разрешению BIOS. Почти всегда прерывание свободно.
13 | Сопроцессор | * 7 | Системное прерывание. Изначально применялось арифметическим сопроцессором, который в первых ПК являлся отдельной микросхемой. Ныне это прерывание зарезервировано для совместимости со старым ПО.
14 | Первичный EIDE-контроллер | 6 | По разрешению BIOS может быть использовано в SCSI- системах.
15 | Вторичный EIDE-контроллер | 5 | Также может использоваться SCSI-интерфейсом, хотя обычно на него "подгружают" дополнительные EIDE-диски. При отсутствии устройств может применяться в любых целях.

Примечания:
15 - наивысший приоритет,
* - эти системные компоненты жестко зафиксированы и их конфигурация не может быть изменена.

При установке в слоты карт расширения необходимо помнить о следующем:

  • слоту AGP и первому слоту PCI присваивается один и тот же номер прерывания
  • если слотов PCI пять, то один номер разделяют также четвертый и пятый слоты
  • при установке сложного устройства, требующего сразу два IRQ, желательно следующий слот оставлять свободным, иначе возможна достаточно сложная процедура ручного присваивания ресурсов.

Ссылки

BIOS

29 июля 2001 года


IRQ n Assigned to

Прерывание с номером n назначено на.... Использование этой опции возможно, если установлен "ручной" режим конфигурации устройств. В данной опции каждому прерыванию системы может быть назначен один из следующих типов устройств:

  • "Legacy ISA" (классические ISA-карты) - обычные карты для ISA-шины, такие как модемы или звуковые карты, без поддержки Plug&Play. Эти карты требуют назначения прерываний в соответствии с документацией на них.
  • "PCI/ISA PnP" (устройства для шин PCI или ISA с поддержкой Plug&Play) - этот параметр устанавливается только для карт расширения на PCI- или ISA-шинах с поддержкой Plug&Play.

Ссылки

BIOS

29 июля 2001 года


IRQ to PCI VGA

Установка этой опции в "Disabled" позволит сэкономить одно прерывание благодаря тому, что графические карты при работе с обычным набором офисных приложений не используют IRQ. Ситуация меняется при установке 3D-акселератора. Выделение аппаратного прерывания для графической карты требуется уже не только для ее корректной работы в системе, а становится необходимым для организации обработки огромных массивов информации, для взаимодействия между центральным процессором, системной памятью и видеопроцессором.

Это же справедливо и для случая, когда карта содержит, например, дополнительный модуль MPEG-декодера. Ведь в этом случае используется режим "Busmastering", при котором карта расширения отбирает у процессора управление потоком данных. Необходимо напомнить, что режим "Busmastering" требует по одному IRQ для каждой из карт, поддерживающих этот режим.

Опция может носить название "Assign IRQ For VGA".

Ссылки

BIOS

29 июля 2001 года


IR Connector

Разъём для инфракрасного излучателя/приемника. Подключается к одному из встроенных COM-портов (обычно COM2) и позволяет установить беспроводную связь с любым устройством, снабженным подобным излучателем и приемником. Интерфейс работает по тому же принципу, что и пульты управления бытовой радиоаппаратурой.

Протокол последовательного интерфейса IrDA версии 1.0 обеспечивал пропускную способность в пределах от 2,4 до 115,2 Кб/с и позволял работать с клавиатурой, мышью, принтером, динамиками, т.п. Версия протокола 1.1 повысила пропускную способность до 1,152 - 4 Мбит/с.

Ссылки

BIOS

26 июля 2001 года


IRQ n Used By ISA

Прерывание n используется на шине ISA. Параметр совпадает с IRQ n Assigned to и может принимать значения:

  • No/ICU (нет/конфигурационная утилита для ISA) - если установлено это значение, то BIOS может распоряжаться этим прерыванием по своему усмотрению. Для DOS настройка параметров в этом случае может также выполняться с помощью программы ISA Configuration Utility от Intel
  • Yes (да) - означает принудительное освобождение прерывания для какой-либо карты на шине ISA, не поддерживающей режим Plug&Play. Рекомендуется всегда указывать Yes для таких карт и нужных им прерываний, так как в противном случае BIOS может назначить прерывание, жестко используемое какой-либо картой на ISA, другой карте, что может вызвать даже прекращение нормальной работы компьютера.

Ссылки

BIOS

3 сентября 2001 года


ISA Bus Clock

Опция установки тактовой частоты ISA-шины. Стандартное значение скорости ISA-шины составляет около 8,33 МГц. В отличие от устаревших систем, ныне скорость ISA-шины напрямую связана со скоростью PCI-шины через т.н. "южный" мост. Можно установить более высокую скорость шины, выбрав соответствующий параметр (делитель). Этот параметр делит действительную скорость PCI-шины и тем самым задает скорость ISA-шины.

Например, тактовая частота PCI-шины составляет 33 МГц. Если изменить делитель с PCICLK/4 на PCICLK/3, то ISA-шина будет работать с частотой 11 МГц. Но необходимо помнить, что повышение тактовой частоты может привести к перегреву элементов ISA-карты и выходу ее из строя. В лучшем случае может возрасти риск ошибок при работе, особенно это опасно для контроллеров дисков (в случае устаревших систем). И хотя многие ISA-устройства работают на более высоких скоростях, необходимо снизить скорость шины, если какое-либо ISA-устройство функционирует неверно.

Из вышесказанного следует, что для правильной установки тактовой частоты ISA-шины необходимо знать тактовую частоту PCI-шины. В данном случае речь идет о том, что в первых системах с использованием PCI-шины частота самой PCI-шины зависила от системной тактовой частоты и поэтому имела ряд значений: 25, 30 и 33 МГц, т.п. В более "старых" системах частота ISA-шины была "привязана" к системной частоте, которая колебалась от 16 до 50 МГц, тем самым давая простор и для ISA-шины.

Опция в разное время носила и разные названия:

  • ISA Clock
  • ISA Clock Frequency
  • ISA Bus Clock Frequency
  • ISA Bus Clock Option
  • ISA Bus Speed
  • ISA Clock Select
  • ISA Clock Divisor
  • AT BUS Clock
  • AT Bus Clock Frequency
  • AT BUS Clock Selection

Наличие в названиях опций сочетания "AT Bus" свидетельствует о "старости" опций. Стоит напомнить, что 8.33 МГц - это "стаpая" тактовая частота шины IBM AT. Ну и, наконец, ряд возможных параметров для выбора: PCI (или PCICLK, или CLK {для системной шины}) / 2,3,4,5,6,8,10, и даже 12, а также фиксированное значение - "7.159 MHz" (оно может устанавливаться и по умолчанию). Опять необходимо дополнительно отметить, что некотоpые системные интерфейсные ISA-платы разрабатывались для такой фиксированной частоты.

Несколько другое содержание заключено в опции "ISA Clock Select Enable". Установив опцию в "Disabled", мы получаем стандартную частоту ISA-шины (PCI/4), выбрав же "Enabled", получаем возможность поварьировать частотой шины вручную.

Ссылки

BIOS

28 июля 2001 года


ISA MEM Block BASE

Базовый адрес блока памяти для ISA. Hекоторые карты для шины ISA требуют доступа к памяти, расположенной на такой карте по определенным адресам. Поэтому и возникла необходимость в этом параметре BIOS.

Может принимать значения:

  • No/ICU (нет/ICU) - оставляет управление этим параметром на усмотрение BIOS или программы ICU
  • C800
  • CC00
  • D000
  • D400
  • D800
  • DC00 - указывается адрес блока памяти

Кроме этого, появляется дополнительный параметр ISA MEM Block Size (размер блока памяти), который нужен в том случае, если таких ISA карт несколько и этот параметр может принимать значения:

  • 8K
  • 16K
  • 32K
  • 64K

Ссылки

BIOS

3 сентября 2001 года


Init AGP Display First

При установке в "Enabled" первичным в системе становится дисплей, подключенный к AGP-карте. Если выбрано значение "Disabled", то тон будет задавать PCI-карта или даже ISA.

Аналогично функционирует и опция "Init Display First" с параметрами "AGP" и "PCI" ("PCI Slot"). При наличии в системе одного видеоадаптера эти опции не вызывают проблем. При установке же двух видеоадаптеров, поддерживаемых на уровне операционной системы, необходимо выбрать не только наиболее производительный, но и, что вполне реально, единственный вариант подключения двух дисплеев. Речь идет о ситуациях, когда PCI-адаптер не сможет работать вторым.

Опять таки аналогично функционирует опция "VGA BIOS Sequence" (последовательность загрузки BIOS видеокарт) с параметрами "PCI/AGP" и "AGP/PCI".

Несколько иной вариант выбора предлагает опция "Init Display First" в случае интегрирования видеоадаптера на материнскую плату. Значения могут такие:

  • Onboard
  • PCI Slot

Напоследок более "древний" вариант аналогичной функции под названием "Graphics Adaptor" с параметрами "VL Bus" и "PCI Bus".

Ссылки

BIOS

28 июля 2001 года


IrDA

Аббревиатура от "Infrared Data (иногда как Device) Association". Так же называется интерфейс с использованием инфракрасного порта, обеспечивающего беспроводное подключение периферийных устройств низкого быстродействия, которые расположены в непосредственной близости от ПК.

Ссылки

BIOS

26 июля 2001 года


KBC Input Clock

Контроль частоты тактового сигнала контроллера клавиатуры. Параметром задается, проще говоря, скорость, с которой центральный процессор связывается с контроллером клавиатуры. Таким образом, параметр служит для изменения скоростных характеристик работы клавиатуры и повышения стабильности ее работы. Значение параметра как "12 MHz" устанавливается по умолчанию. Если возникли проблемы при работе с клавиатурой, необходимо уменьшить значение параметра. Параметр может принимать значения:

  • 8 MHz
  • 12 MHz
  • 16 MHz

Опция также может носить названия: "KBC Input Clock Select", "Кeyboard Controller Clock".

В общем-то, это уже устаревшая функция, позволявшая в соответствии со спецификациями инсталлированного контроллера клавиатуры устанавливать либо фиксированные значения, например, 7.16 МГц, 9.5 МГц, другие значения, либо получать значения как частное от частоты системной или локальной шины.

Ссылки

BIOS

26 июля 2001 года


Keyboard

Клавиатура. Значение "Installed" не вызывает вопросов. Если установить "not installed", эта опция укажет BIOS на отмену пpовеpки клавиатуpы во вpемя стаpтового теста, что позволяет пеpезапускать ПК с отключенной клавиатуpой без выдачи сообщения об ошибке теста клавиатуpы. Это может оказаться необходимым при работе файл-сервера, сервера печати, в т.ч. из соображений безопасности.

Аналогичную задачу решает опция "System Keyboard" (AMI BIOS) с параметрами "Present" (по умолчанию) и "Absent".

Ссылки

BIOS

11 июля 2001 года


Keyboard/Mouse Power On

Для использования этой функц и в некоторых случаях возможно придется переставить в положение "On" соответствующую перемычку на материнской плате, например, под названием "The Wake-On-Keyboard/Mouse". В этом случае при использовании режимов энергосбережения система будет просыпаться при воздействии на "мышь" или клавиатуру. Может принимать значения:

  • Disabled (по умолчанию)
  • Password
  • Hot Key
  • Mouse Left
  • Mouse Right
  • Any Key
  • Keyboard 98

Ссылки

BIOS

28 июля 2001 года


MPS 1.4 Support

Поддержка режима MPS 1.4 (Intel Multiprocessor Specification). Этот параметр появляется только в BIOS материнских плат, допускающих установку нескольких процессоров. Параметр указывает операционной системе, какую версию мультипроцессорной спецификации поддерживает плата. В MPS версии 1.4 добавлена поддержка расширенной таблицы, улучшающей работу с несколькими PCI-портами. При запрещении устанавливается режим MPS 1.1. Большинство современных серверных мультипроцессорных ОС поддерживают режим MPS 1.4. Рекомендуется устанавливать режим MPS 1.1 ("Disabled") только при работе со старыми операционными системами, в т.ч. различными версиями ОС "Windows". Для "Windows NT", "Novell Netware" естественно рекомендуется "Enabled".

Ссылки

BIOS

28 июля 2001 года


MPS Version Control For OS

Аналогичная опция со следующими значениями:

  • 1.4 (по умолчанию)
  • 1.1

Ссылки

BIOS

28 июля 2001 года


Master Retry Timer

Этой опцией устанавливается, как долго центральный процессор, будучи задатчиком PCI-циклов, сможет сохранить свое лидерство. Возможные параметры измеряются в циклах PCI-шины (PCICLKs). Вот этот ряд:

  • 10 (по умолчанию)
  • 18
  • 34
  • 66 PCICLKs.

Ссылки

BIOS

26 июля 2001 года


Memory Hole At 15M-16M

Буквально - "дырка" в памяти в диапазоне 15-16 МБ). При включенном состоянии параметра система, для повышения производительности, будет копировать более медленную память устройства, подключенного к ISA-шине, в более быструю основную память. Это происходит за счет выделения специальной области памяти и перемещения в нее данных ROM-памяти карты расширения или устройства сопряжения.

Естественно, что действие этой функции представляет собой механизм "эатенения", который позволяет обращаться, в данном случае к устройствам ввода/вывода, как к адресному пространству ОЗУ и за счет этого увеличить скорость доступа к таким устройствам. Для функционирования этого механизма необходимо исключить для всех обычных программ возможность использования указанной области памяти, что и делает BIOS при разрешении этого параметра. При отсутствии ISA-устройств данная опция должна быть отключена. По умолчанию эта опция включена.

И еще одно уточнение. Разрешать этот параметр следует в том случае, если это требуется в документации на используемую в системе плату. Некоторые старые ISA-карты (например, ранние видеокарты высокого разрешения) требуют выделения для них специального адреса памяти, лежащего в некотором диапазоне. Кроме того, это выделение запрещает доступ в старшие адреса памяти, расположенные выше 16 МБ. Поэтому включение данной опции должно быть оправдано.

По сути, данная функция сохранена в "BIOS SETUP" по причине фактора совместимости со старыми картами. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

В других версиях BIOS могут встретиться значения:

  • Disabled
  • 14M-16M
    • 15M-16M

В более "старых" версиях BIOS могут встретиться другое наименование такой функции - "Memory Hole", и значения параметров:

  • None
  • at 512 kB
  • at 15 MB

Действие некоторых параметров уже понятно, а для значения "at 512 kB" стоит указать, что для "затенения" используется часть базовой памяти в пределах 512-639 КБ. Опция может носить название "Local Memory 15-16M" или "Memory Hole at 15M Addr.".

Ссылки

BIOS

12 июля 2001 года


Memory Test Tick Sound

Опция, позволяющая сопровождать тест памяти периодическими звуковыми сигналами. Рекомендуется устанавливать в "Enabled" для озвучивания пpоцесса загpузки и дополнительного подтверждения, в частности, правильности установок "CPU clock speed/ Turbo switch".

Ссылки

BIOS

26 июля 2001 года


NA# Enable

Опция включения/отключения сигнала NA (Next Address). Установив "Enabled", мы включаем механизм конвейеризации, при которой чипсет сигнализирует центральному процессору о выдаче нового адреса памяти еще до того, как все данные, переданные в текущем цикле, будут обработаны. Естественно, что включение такого режима повышает производительность системы.

То же содержание заключено в опции под названием "NA# Pin Assertion".

Ссылки

BIOS

12 июля 2001 года


Numeric Processor Test

Тест цифрового пpоцессоpа. Речь в данной опции идет о проверке математического сопроцессора (FPU - Floating Point Unit). Хотя эта опция и устарела, но тем не менее парк стареньких ПК еще не исчез бесследно. Устанавливается в "Disabled", если сопроцессор отсутствует (386SX, 386DX, 486SX, 486SLC, 486DLC, более низкие модели). Пpи отключении этого теста сопpоцессоp, если он даже и пpисутствует в системе, не pаспознается и считается отсутствующим.

Ссылки

BIOS

26 июля 2001 года


ONB AHA BIOS First

Запуск BIOS контроллера "Adaptec" первым. Параметр разрешает/запрещает запуск BIOS встроенного контроллера "Adaptec" до запуска любого другого SCSI-контроллера. Может принимать значения:

  • "Yes" - разрешено
  • "No" - запрещено

Ссылки

BIOS

28 июля 2001 года


ONB SCSI LVD Term.

Терминаторы встроенного контроллера SCSI LVD. Параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном контроллере SCSI с LVD-передачей сигналов. Управление этим параметром позволяет значительно увеличить длину соединительного SCSI-кабеля. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

28 июля 2001 года


ONB SCSI SE Term.

Терминаторы встроенного контроллера SCSI SE. Параметр разрешает/запрещает подключение нагрузочных резисторов (терминаторов) на встроенном SCSI-контроллере с SE-передачей данных. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

28 июля 2001 года


On Board PCI/SCSI BIOS

Установка значения "Enabled" (включено) необходима, если на материнской плате имеется встроенный SCSI-контроллер, подключенный к PCI-шине, и используется жесткий диск с интерфейсом SCSI. Стоит напомнить, что в процессе загрузки одновременное нажатие клавиш + вызывает BIOS SCSI. Об этом подробнее будет сказано чуть ниже. Может принимать значения:

  • "Enabled" - включено
  • "Disabled" - отключено

Опция может называться также "Onboard PCI SCSI Chip".

Ссылки

BIOS

28 июля 2001 года


Onboard AHA BIOS

BIOS встроенного SCSI-контроллера "Adaptec". Параметр разрешает/запрещает выполнение BIOS-функций встроенного SCSI-контроллера и тем самым разрешает/запрещает его работу. Параметр может принимать значения:

  • "AUTO" - разрешен автоматический поиск SCSI-контроллера "Adaptec" и запуск BIOS для него
  • "Disabled" (запрещено) - выбор этого значения рекомендуется при отсутствии SCSI-карты

Необходимо помнить, что некоторые SCSI-контроллеры той же фирмы "Adaptec", например "AHA-2940AU", не имеют собственного Flash-BIOS, и их конфигурирование осуществляется в BIOS компьютера и средствами ОС.

Ссылки

BIOS

28 июля 2001 года


Onboard PCI IDE Enable

Разрешение работы интегрированного контроллера IDE. Этот параметр управляет разрешением/запрещением работы каждого из двух каналов контроллера IDE, установленного на материнской плате. Может принимать значения:

  • Primary - разрешена работа только первого канала
  • Secondary - разрешена работа только второго канала
  • Both - разрешена работа обоих каналов
  • Disable - запрещена работа обоих каналов

Ссылки

BIOS

3 сентября 2001 года


OS/2 Onboard Memory > 64MB

Выбор значения для OS/2, если памяти больше, чем 64 Mb. Требует разрешения при выполнении двух условий - в компьютере установлено больше, чем 64 Mb памяти и используется OS/2 в качестве операционной системы. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

28 июля 2001 года


Parallel Port Mode (ECP+EPP)

Режим работы параллельного порта. Параметр позволяет задать режимы работы параллельного порта. Следует учитывать, что скорость обмена для некоторых устройств может быть существенно увеличена при правильной установке режима работы порта принтера, например, для внешних устройств хранения информации типа Iomega ZIP Drive LPT. Может принимать значения:

  • Normal - обычный интерфейс принтера, также называется SPP
  • ECP - порт с расширенными возможностями
  • EPP - расширенный принтерный порт
  • ECP+EPP - можно использовать оба режима

Ссылки

BIOS

3 сентября 2001 года


PCI 2.1 Support

Поддержка спецификации шины PCI 2.1. При разрешении этого параметра поддерживаются возможности спецификации 2.1 шины PCI. Спецификация 2.1 имеет два основных отличия от спецификации 2.0: максимальная тактовая частота шины увеличена до 66 МГц и вводится механизм моста PCI-PCI, позволяющий снять ограничение спецификации 2.0, согласно которой допускается установка не более 4-х устройств на шине. Запрещение этого параметра имеет смысл только при возникновении проблем после установки дополнительной PCI-платы (как правило, проблемы могут возникнуть только с достаточно старыми PCI-устройствами). Параметр может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Опция может называться "PCI 2.1 Compliance".

Ссылки

BIOS

26 июля 2001 года


PCI Bus Arbitration

Параметр может принимать значения:

  • Rotating
  • Fixed

Опция с абсолютно таким же названием встретилась и с параметрами: "Favor CPU" и "Favor PCI". Пользователю остается определить своего фаворита. Если речь идет о потоковом видео, то желательно указать PCI-устройство. Выбор центрального процессора во многих случаях может оказаться более безопасным.

С абсолютно такими же возможностями отбора: CPU или PCI, может встретиться и функция "Arbitration Priority".

В свою очередь, функция с таким же названием может предложить более "изощренный" вариант: "PCI First" и "ISA/DMA First". Здесь возможности выбора зависят от применяемых устройств. "Master"-устройство может находиться и на ISA-шине и желать того же самого, а именно передачи данных напрямую по DMA-каналам.

Аналогичные варианты выбора предлагает и функция "DMA/ISA Master Before PCI". В данном случае значение "Disabled" равносильно "PCI First".

Рассмотренные выше варианты выбора параметров могут быть предложены и в функциях "PCI Arbiter Mode", "PCI Arbitration Mode", "PCI Arbit. Rotate Priority".

При этом, правда, могут возникнуть и другие сложности. Например, если для выбора предлагаются параметры: "Mode1" и "Mode2"? Поскольку идея арбитража заключается и в минимизации времени, требуемого для получения устройством контроля над шиной и передачи данных, то возникает вопрос, в каком из вариантов устройство, например, на той же PCI-шине быстрее получит доступ к ней. В случае "Favor PCI" или с выбором "Favor CPU"? Естественно, что первый вариант более оптимален. В данном случае этому значению соответствует "Mode1", устанавливаемый по умолчанию. При возникновении каких-либо проблем в системе необходимо выбрать режим "Mode2", как более безопасный.

Ссылки

BIOS

26 июля 2001 года


PCI Bus Parking

Опция включения/выключения режима "парковки" устройств на PCI-шине. Режим "парковки" - одна из разновидностей режима "Bus-Master". Когда этот режим включен ("Enabled"), "запаркованные" на PCI-шине устройства будут иметь полный контроль над шиной в течение некоторого небольшого промежутка времени. Это повышает производительность данного устройства, однако приостанавливает работу остальных. Данный режим неплохо работает с контроллерами жестких дисков.

Ссылки

BIOS

26 июля 2001 года


PCI Clock Frequency

Опция для установки частоты шины PCI. В приведенном виде такая опция была внедрена на первых "пентиумных" машинах, а затем перенесена на 486-е системы с процессорами AMD и PCI-шиной. Частота шины через множитель "привязывалась" к частоте центрального процессора и имела следующий ряд значений:

  • CPUCLK/1.5 (по умолчанию)
  • CPUCLK/2
  • CPUCLK/3
  • 14 Mhz

Ссылки

BIOS

26 июля 2001 года


PCI Dynamic Decoding

Установка в "Enabled" позволяет системе запоминать PCI-команду, которая только что была запрошена. Если последующие команды совпадают с некоторой адресной областью, циклы записи будут автоматически интерпретироваться как PCI-команды.

Ссылки

BIOS

26 июля 2001 года


PCI IDE IRQ Map to

Прерывания контроллера IDE на PCI отображаются на... Позволяет освободить прерывания, занимаемые контроллером IDE на шине PCI в случае его отсутствия (или запрещения) на материнской плате и отдать их устройствам на шине ISA. Стандартные прерывания для ISA - IRQ 14 для первого канала и IRQ 15 для второго канала. Может принимать значения:

  • PCI IDE IRQ mapping (используется для PCI IDE)
  • PC AT (ISA) (используется для ISA)

Ссылки

BIOS

3 сентября 2001 года


PCI IRQ Activated by

Прерывания активизируются по ... . Выбор метода, с помощью которого контроллер прерываний будет распознавать запрос на прерывание от устройств на шине PCI. Смысл опции - в минимизации времени "захвата" шины и дальнейшей передачи данных от устройства. По умолчанию предлагается значение "Level", и менять его не следует, если только это не будет необходимо для конкретного случая, о чем должно быть написано в руководстве к устройству. Параметр может принимать значения:

  • "Level" (уровень) - контроллер прерываний реагирует только на уровень сигнала
  • "Edge" (перепад) - контроллер прерываний реагирует только на перепад уровня сигнала

Ссылки

BIOS

29 июля 2001 года


PCI Latency Timer

Таймер времени ожидания для шины PCI. Значение этой опции указывает, в течение какого времени (в системных тактах) поддерживающая режим "Busmaster" PCI-карта может сохранять контроль над PCI-шиной, если к шине обращается другая PCI-карта. Фактически это и есть таймер, ограничивающий время занятия PCI-шины устройством-задатчиком шины. По истечении заданного времени арбитр шины принудительно отбирает шину у задатчика, передавая ее другому устройству.

Допустимый диапазон изменения этого параметра - от 16 до 128 с шагом, кратным 8.

Значение параметра необходимо изменять осторожно, так как оно зависит от конкретной реализации материнской платы, и только в случае, если в системе установлены по меньшей мере две PCI-карты, поддерживающие режим "Busmaster", например, SCSI- и сетевая карты. Графические карты не поддерживают режим "Busmaster". Чем меньше устанавливаемое значение, тем быстрее другая PCI-карта, требующая доступа, получит доступ к шине. Если требуется выделить для работы, например, SCSI-карты больше времени, то можно увеличить значение для PCI-слота, в котором она находится. Значение для сетевой карты, например, соответственно необходимо уменьшить или вообще установить равным 0, хотя в некоторых случаях установка 0 не рекомендуется. В общем случае, какое значение параметра пригодно и оптимально для данной системы, зависит от применяемых PCI-карт и проверяется с помощью тестовых программ. Необходимо также учитывать, в какой степени "карты-конкуренты" чувствительны к возможным задержкам. Опция также может носить названия:

  • PCI Bus Time-out
  • PCI Master Latency
  • Latency Timer
  • PCI Clocks
  • PCI Initial Latency Timer

Для последней опции ряд возможных значений имел вид:

  • Disabled
  • 16 Clocks
  • 24 Clocks
  • 32 Clocks

Правда, это еще не весь возможный перечень. Функции "Latency Timer Value" и "Default Latency Timer Value" применяются совместно. Если в последней опции установить "Yes" (оно же и по умолчанию), то тогда первая функция будет проигнорирована.

И еще одно очень важное замечание. В свое время эта опция (и ей подобные) вводились с учетом совместного существования PCI- и ISA-шин. ISA-шина позволяла использовать одно "master"-устройство. Это применялось редко как раньше, так и теперь. Зато PCI-шина дала возможность одновременного использования нескольких "master"-устройств. Учитывая различия в скорости шин, а тем более в их пропускной способности, необходимо было решить проблему совместной работы "master"-устройств на PCI-шине и стандартных устройств на более медленной ISA-шине. Особенно это касалось распространенных в то время звуковых и сетевых карт для ISA-шины, обладавших незначительным объемом буферной памяти, т.е. чувствительных к любым задержкам при передаче данных. "AMI BIOS" позволял выбрать значение параметра в диапазоне от 0 до 255 с единичным шагом. Значение "66" устанавливалось по умолчанию, хотя меньшее значение владения шиной PCI-устройством оказывалось более предпочтительным.

Поэтому при конкретном решении стоящей перед пользователем задачи (или проблемы) надо исходить прежде всего из возможностей чипсета, версии BIOS и используемых карт расширения.

Ссылки

BIOS

26 июля 2001 года


PCI Master 0 WS Write

Если опция установлена в "Enabled", в системе устанавливается нулевое время ожидания в циклах записи от "master"-устройств на PCI-шине в системную память. Значение "Disabled" устанавливается по умолчанию.

Ссылки

BIOS

26 июля 2001 года


PCI Preempt Timer

Таймер времени вытеснения для шины PCI. На первый взгляд по смыслу эта функция аналогична функции "PCI Latency Timer", возможна даже некоторая путаница, хотя в данном случае кое-что наоборот. Значение этой опции указывает, в течение какого времени (в тактах PCI-шины, или локальных тактах - LCLKs) поддерживающая режим "Busmaster" PCI-карта сможет не контролировать шину, а находиться в состоянии ожидания пока этой шиной владеет другая карта. Арбитр шины отслеживает указанный временной интервал с момента подачи запроса, после чего ожидающее "master"-устройство вытесняет своего товарища. Для выбора предагаются значения из ряда:

  • 5
  • 12
  • 20
  • 36
  • 68
  • 132
  • 260

в цифровом виде или с отображением единицы измерения - "5 LCLKs" и т.д. Обязательным является параметр "No Preemption" (или "Disabled"). Причем последний, как правило, устанавливается по умолчанию. Эта опция в таком виде уже не применяется, так что встреча с ней на старых машинах может вызвать некоторые трудности. Во всяком случае при наличии хотя бы двух "master"-устройств на PCI-шине значение "Disabled" (или аналогичное) должно быть заменено на более оптимальное.

Опция может называться и "PCI Preemption Timer".

Ссылки

BIOS

26 июля 2001 года


PCI/VGA Palette Snoop

Слежение за палитрой подсистемы видео или корректировка палитры VGA-видеокарты. Эта опция используется только при наличии карты видеозахвата (MPEG-карты) или TV-тюнера, соединенных с графической картой с помощью соединительного шлейфа, и в некоторых других случаях. При установке в "Enabled" функция позволяет корректировать установки VGA-палитры во время прохождения сигналов из MPEG-карты через VGA-коннектор, т.е. в случае некорректного отображения цветов. Собственно суть механизма действия этой функции заключена в способности платы графики в "подсматривании" циклов записи в регистры палитры цветов карты видеозахвата и корректировке цветов в буфере кадров видеоадаптера. VGA-перехват (snooping) используется различными мультимедиа устройствами, например, фрейм-грабберами (захватчиками изображения) или картами MPEG-декомпрессии. В обычном режиме работы опция должна быть запрещена.

Опция также может называться "Video Palette Snoop" или совсем необычно - "Multimedia Mode".

Ссылки

BIOS

28 июля 2001 года


PCI master accesses shadow RAM

Опция включения/выключения возможности копирования ПЗУ шины в более быструю оперативную память для повышения быстродействия системы. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

12 июля 2001 года


PCI to ISA Write Buffer

Во включенном состоянии ("Enabled") система, не прерывая работы процессора, будет временно записывать данные в специальный буфер для последующей передачи данных в наиболее подходящий момент. В противном случае ("Disabled") цикл записи в шину PCI будет направляться далее напрямую в более медленную ISA шину. Необходимость в такой функции, а точнее в таком буфере, связана с тем, что скорости работы ISA- и PCI-шин различны. Включение буферной памяти позволит PCI-шине не ожидать, пока ISA-шина примет все данные.

Ссылки

BIOS

26 июля 2001 года


PNP OS Installed

Установлена ли операционная система с поддержкой режима Plug&Play?. Установить "Yes", если операционная система поддерживает Plug&Play (например, Windows 95), и "No" в противном случае.

Ссылки

BIOS

3 сентября 2001 года


PS/2 Mouse Function Control

Управление функциями порта мыши PS/2. Разрешение этого параметра отдает IRQ12 только для порта мыши PS/2. В противном случае, при отсутствии подключенной к компьютеру мыши с интерфейсом PS/2, IRQ12 свободно для других устройств. Рекомендуется устанавливать значение Auto. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено
  • Auto - BIOS определяет присутствие или отсутствие PS/2 мыши

Ссылки

BIOS

28 июля 2001 года


PWRON After PWR-Fail

Функция восстановления питания после его пропадания. Возможные значения параметра:

  • "On" - автоматическое включение питания ПК после его восстановления
  • "Off" - никакая информация о состоянии системы не сохраняется. Обычный перезапуск компьютера
  • "Former-sts" - система возвращается в состояние, которое было перед пропаданием сетевого напряжения, но только через нажатие кнопки "Power"

Ссылки

BIOS

28 июля 2001 года


PWR Button > 4 Secs

Описание настроек BIOS Setup

PWR Button less then 4 Secs

Кнопка питания нажата менее 4 секунд. Опция управления функциями кнопки "Power" на системном блоке компьютера. Может принимать значения:

  • "Soft Off" - программное выключение. Кнопка работает как обычная кнопка включения/выключения питания компьютера, но при этом разрешается программное выключение компьютера при выходе из "Windows"
  • "Suspend" - временная остановка. При нажатии на кнопку питания на время менее 4 секунд компьютер переходит в состояние "Suspend"
  • "No Function" - функция не задействована. Кнопка "Power" становится обычной кнопкой включения/выключения питания.

Ссылки

BIOS

28 июля 2001 года


PWR Lost Resume State

Опция автоматического включения питания. Может принимать значения:

  • "Keep Off" - при потере питания в сети и его восстановлении для включения ПК необходимо нажать кнопку питания
  • "Turn On" - восстановление питания вызывает автоматическое включение системы
  • "Last State" - к автоматическому включению ПК добавляется возможность восстановления системы в том состоянии, в котором она находилась на момент пропадания питания

Ссылки

BIOS

28 июля 2001 года


Passive Release

Пассивное разделение. Эта опция появилась в свое время в "BIOS Setup" одновременно со способностью арбитра чипсетов Intel Triton VX/HX отбирать шину у "master"-устройств при отсутствии в течение какого-то времени запросов на передачу с их стороны. Эта опция включает/выключает механизм параллельной работы шин ISA и PCI. Если этот параметр разрешен ("Enabled"), то доступ процессора к шине PCI позволен во время "пассивного разделения" или, как говорят иногда, ее "освобождения". Проще говоря, включение данного режима позволяет шине PCI продолжать работу даже тогда, когда происходит передача данных от ISA- устройств, которые в обычном режиме могут тормозить работу более скоростной PCI-шины. Арбитр чипсета как бы выравнивает работу двух шин с учетом задержек ISA-шины. Необходимость же запрещения данного параметра может возникнуть при использовании плат ISA, активно использующих каналы DMA (звуковые карты, устройства "Arwid"). Запрещение также уместно при отсутствии ISA-карт в системе.

Опция может называться "PCI Passive Release".

Ссылки

BIOS

26 июля 2001 года


Password Checking

Опция "AMI BIOS", аналогичная "Security Option" для "Award BIOS", с той лишь разницей, что значению "System" соответствует значение "Always", но только лишь с блокировкой загрузки системы.

Ссылки

BIOS

28 июля 2001 года


Peer Concurrency

Параллельная работа или, дословно, - равноправная конкуренция. Этот параметр разрешает/запрещает одновременную работу нескольких устройств на PCI-шине. При включении опции включается дополнительное буферирование циклов чтения/записи в чипсете. Но могут возникнуть проблемы, если не все PCI-карты готовы поддерживать такой режим работы. В этом случае работоспособность системы проверяется опытным путем.

Действие этой опции затрагивает и совместную работу PCI- и ISA-шин. Например, шинные PCI-циклы могут перераспределяться и буферизироваться во время ISA-операций, таких как передача по DMA-каналам в режиме "Bus-Master". Параметр может принимать значения:

  • "Enabled" (по умолчанию) - разрешено
  • "Disabled" - запрещено

Опция может называться и "PCI Concurrency" или "Bus Concurrency". Дополнительные устройства, "жаждущие конкуренции", появляются в опциях "PCI/IDE Concurrency" или "PCI-to-IDE Concurrency".

Ссылки

BIOS

26 июля 2001 года


Plug and Play

В 1993 г. "Compaq", "Intel", "Phoenix" и "Microsoft", стремясь сделать ПК еще более интеллектуальными, разработали концепцию "Plug and Play". Основная ее идея заключается в следующем: при загрузке ПК BIOS опрашивает все карты на предмет их потребности в ресурсах и распределяет их так, чтобы при работе ПК не возникали конфликтные ситуации.

Общение между картой расширения и BIOS можно обеспечить еще эффективнее при использовании PCI-шины. Так, большинство PnP-карт разработаны только для шины PCI. Все PCI-карты отличаются, кроме того, дополнительными способностями. В отличие от своих ISA-родственников они могут работать с переменными ресурсами и посредством точно определенной идентификационной записи отчетливо заявлять о своих ресурсных потребностях.

Соответственно этому BIOS, поддерживающий "Plug and Play", сперва проверяет жестко настроенные ISA-карты, а затем раздает оставшиеся ресурсы PCI-устройствам. В результате формируется список распределения ресурсов ESCD (Extended System Configuration Data), помещаемый BIOS'ом в нечувствительной к отсутствию питания области памяти для того, чтобы при каждом старте иметь возможность сравнения и восстановления последней функционировавшей комбинации.

Ссылки

BIOS

26 июля 2001 года


Power Button Function

Опция отключения системы, во многом аналогичная последующим функциям. Может принимать значения:

  • "On/Off" - в этом случае включение ПК и его отключение производится от кратковременного нажатия кнопки "POWER"
  • "Suspend" - при включенном состоянии ПК кратковременное нажатие кнопки питания активирует режим "Suspend". При более длительном удержании кнопки (более 4 сек.) система отключается.

Ссылки

BIOS

28 июля 2001 года


Power Management - ACPI

Примерно с конца 1994 г. каждый ПК стал соответствовать спецификации "Energy Star" (наличие функций энергосбережения), а BIOS компьютера обогатился встроенными функциями т.н. "Advanced Power Management" (APM) - совместного стандарта корпораций "Microsoft" и "Intel", первая редакция которого появилась еще в 1992 г. В компьютерную терминологию "Energy Star" вошла от названия одноименной программы правительства США по снижению энергопотребления. Соответствующий логотип могли получить только те продукты, которые выполняли квоту по экономии энергии.

"APM" был первой спецификацией для изготовителей ПК, которая установила взаимодействие между операционной системой и BIOS в задаче управления энергопотреблением (Power Management).

"ACPI" (Advanced Configuration and Power Interface) - интерфейс расширенного конфигурирования и управления питанием, заменяющий стандарт расширенного управления питанием (APM). ACPI - это технология, лежащая в основе разработанного "Microsoft" стандарта энергосбережения и стандарта "Plug-and-Play" - "On Now".

Спецификация разрабатывалась совместно "Intel", "Microsoft" и "Toshiba" и представляла собой новую архитектуру "Microsoft Windows 98". Операционная система взяла на себя управление многочисленными параметрами функционирования ПК. Технология реализует управление состоянием системы, работой компонентов и энергопотреблением на основе модели событий и использования программирования по таймеру.

Все это достигается средствами ОС и представляет собой программируемый вход в режимы энергосбережения, а также выход из "спящего" режима от обращения к "мыши" или клавиатуре, в связи с приходом телефонного звонка или удаленного сетевого управления, т.п. Системный BIOS дополнился и другими многочисленными функциями, о которых будет рассказано далее. Присутствие в этой троице "Toshiba" более чем объяснимо, поскольку проблемы и задачи энергосбережения пришли в мир настольных ПК от ПК-блокнотов.

Спецификация "ACPI" была реализована "Intel" впервые в чипсете 440LX с одновременной реализацией архитектуры AGP.

Параллельно с развитием и совершенствованием технологий энергосбережения, затрагивающих прежде всего производителей чипсетов, материнских плат, BIOS и разработчиков операционных систем, шел процесс совершенствования моделей мониторов. Стандарт "EPA Energy Star VESA DPMS" (DPMS - Display Power Management System) определил унифицированную процедуру энергосбережения и ступенчатого выключения монитора в трех стадиях:

  • "On" (номинальный режим работы) >
  • "Standbye" (режим ожидания). В режиме ожидания изображение на экране пропадает, но внутренние компоненты монитора функционируют в нормальном режиме, а энергопотребление снижается до 80% от рабочего состояния >
  • "Suspend" (режим приостановки). В режиме приостановки, как правило, отключаются высоковольтные узлы, а потребление энергии падает до 30 Вт и менее >
  • "Off" ("сон"). В режиме так называемого "сна" монитор потребляет не более 8 Вт, а функционирует у него только микропроцессор. В этой системной процедуре контроль берет на себя драйвер, посылающий соответствующие сигналы через графическую карту. При нажатии клавиши на клавиатуре или движении "мыши" монитор переходит в нормальный режим работы.

Ссылки

BIOS

28 июля 2001 года


Preempt PCI Master Option

Когда опция включена ("Enabled"), операции чтения/записи на PCI-шине, даже в том случае, когда шиной владеет "master"- устройство, могут быть прерваны некоторыми системными операциями, например, такими, как регенерация памяти. В противном случае может вестись "незапланированная" параллельная работа различных системных компонент, что может привести к сбоям системы, в лучшем случае - к потере информации.

Ссылки

BIOS

26 июля 2001 года


Processor Number Feature

Опция для установки автоматического считывания и вывода информации о встроенном серийном номере процессора Pentium III в BIOS материнских плат, поддерживающих его установку. Для реализации такой возможности, естественно, требуется значение параметра как "Enabled". Во всех остальных случаях устанавливается значение "Disabled". Оно же устанавливается по умолчанию.

Опция может носить название "Processor S/N".

Ссылки

BIOS

26 июля 2001 года


Quick Power On Self Test

Быстрый тест компьютера после включения питания. Разрешение этого параметра приводит к некоторому сокращению времени на начальное самотестирование компьютера (POST), особенно при значительных объемах оперативной памяти. Следует только учесть, что память, например, в этом случае не тестируется, а только проверяется ее размер. Сокращение времени тестирования происходит также за счет пропуска некоторых пунктов проверки. Если при работе ПК возникают какие-либо проблемы, то лучше при его включении осуществлять полный тест. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено (по умолчанию)

"AMI BIOS" может содержать аналогичную опцию под названием "Quick Boot".

Ссылки

BIOS

26 июля 2001 года


RTC Alarm Resume (From Soft)

При установке опции в "Enabled" система проснется, а точнее включится, в указанное время, устанавливаемое в следующих 4-х полях:

  • RTC Alarm Date
  • RTC Alarm Hour
  • RTC Alarm Minute
  • RTC Alarm Second

Из этого нетрудно увидеть, что при установке конкретной даты система запустится только один раз в месяц. Поэтому в этом поле предусмотрен и отказ от указания какого-либо числа месяца. Уже из названия функции следует, что за временем зорко следят "часы реального времени" (real-time clock), выводя систему из режима Suspend.

Опция может также называться "RTC Wake Up Timer".

Ссылки

BIOS

28 июля 2001 года


RTC Y2K H/W Roll Over

При установке опции в "Enabled" происходит тестирование системы на проблему 2000 года. "Disabled" устанавливается по умолчанию.

Ссылки

BIOS

26 июля 2001 года


Ref/Act Command Delay

Установка режима работы памяти. Параметром выбирается время задержки между окончанием режима регенерации и началом командного режима. Может принимать значения:

  • 5T
  • 6T (по умолчанию)
  • 7T
  • 8T

Ссылки

BIOS

12 июля 2001 года


Refresh

Возможны три различных метода регенерации данных. Регенерация одним RAS (RAS Only Refresh - ROR). Этот метод использовался еще в первых микросхемах DRAM. Адрес регенерируемой строки передается на шину адреса и выдается сигнал RAS (точно так же, как при чтении или записи). При этом выбирается строка ячеек, и данные из них поступают на внутренние цепи микросхемы, после чего записываются обратно. Так как далее сигнал CAS не следует, цикл чтения/записи не начинается. Затем передается адрес следующей строки и так далее, пока не будет пройдена вся матрица памяти, после чего цикл регенерации повторяется. К недостаткам этого метода можно отнести то, что занимается шина адреса, и в момент регенерации блокируется доступ к другим подсистемам компьютера.

CAS перед RAS (CAS Before RAS - CBR) - стандартный метод регенерации. При нормальном цикле чтения/записи сигнал RAS всегда приходит первым, за ним следует CAS. Если же CAS приходит раньше RAS, то начинается специальный цикл регенерации - CBR. При этом адрес строки не передается, а микросхема использует свой внутренний счетчик, содержимое которого увеличивается на 1 при каждом CBR-цикле (т.н. инкрементирование адреса строки). Этот режим позволяет регенерировать память, не занимая шину адреса, что, безусловно, более экономично.

Автоматическая регенерация памяти (Self Refresh - SR, или саморегенерация). Этот метод обычно используется в режиме энергосбережения, когда система переходит в состояние "сна" ("suspend"), и тактовый генератор перестает работать. В таком состоянии обновление памяти по вышеописанным методам невозможно (попросту отсутствуют источники сигналов), и микросхема памяти выполняет регенерацию самостоятельно. В ней запускается свой собственный генератор, который тактирует внутренние цепи регенерации. Такая технология работы памяти была внедрена с появлением EDO DRAM. Необходимо отметить, что в режиме "сна" память потребляет очень малый ток.

Ссылки

BIOS

26 июля 2001 года


Refresh During PCI Cycles

Опция, разрешающая/запрещающая проведение регенерации памяти во время циклов чтения/записи на шине PCI. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Ссылки

BIOS

12 июля 2001 года


Refresh RAS# Assertion

Установка периода активности сигнала RAS. Этим параметром устанавливается длительность сигнала RAS (в тактах системной шины) для цикла регенерации. Принимаемые значения определяются качеством памяти и чипсетом. Меньшее значение увеличивает производительность системы. Может принимать значения:

  • 4T (или "4 Clks")
  • 5T (или "5 Clks")

Опция может называться также "Refresh Assertion" или "Refresh RAS Active Time".

Ссылки

BIOS

12 июля 2001 года


Report No FDD For WIN 95

Сообщение об отсутствии накопителя на гибких дисках для "Windows 95". Параметр используется, как правило, в сетевых компьютерах без флоппи-дисковода или в случае необходимости размещения в компьютере устройства, для которого не хватает прерывания. При выборе "Yes" и одновременном выборе "Disable" в параметре "Onboard FDC Controller" (обычно в разделе "Integrated Peripherals" "BIOS Setup") "Windows 9x" освободит IRQ6, занимаемое контроллером флоппи-дисковода, для использования другим устройством. Может принимать значения:

  • "Yes" (или "Enabled") - освободить IRQ6
  • "No" (или "Disabled") - не освобождать (независимо от того, есть ли флоппи-дисковод или нет)

Ссылки

BIOS

29 июля 2001 года


Reset Configuration Data

Cброс конфигурационных данных. Рекомендуется устанавливать опцию в "Disabled" при условии постоянства всей подключенной периферии и ее конфигурирования. При установке "Enabled" BIOS очистит область памяти ESCD (Extended System Configuration Data - данные расширенной системной конфигурации), в которой хранятся данные о конфигурировании системы, и перезапишет ее в процессе проведения POST. Затем BIOS автоматически переведет значение параметра в "Disabled", предотвращая систему от ошибок пользователя.

Естественно, что при постоянстве параметра "Enabled" также постоянно происходило бы переконфигурирование распределения системных ресурсов. Опция может быть включена для перенастройки таблицы ресурсов либо при установке новых устройств.

Опция также может называться "Force Update ESCD".

Ссылки

BIOS

26 июля 2001 года


Resources Controlled By

Как управляются ресурсы. Если выбрано AUTO, то BIOS сам автоматически назначит прерывания и каналы DMA всем устройствам, подключенным к шине PCI и эти параметры не будут появляться на экране. В противном случае все эти параметры следует установить вручную. В некоторых вариантах BIOS этот параметр может устанавливаться индивидуально для каждого PCI слота и выглядеть так:

  • Slot 1 IRQ
  • Slot 2 IRQ
  • и т.д.

Ссылки

BIOS

3 сентября 2001 года


Resume by Ring

При установке опции в "Enabled" входящий звонок приводит к "пробуждению" системы. При входящем звонке прежде всего активизируется линия модема и последовательного интерфейса Ring Indicator. По умолчанию опция устанавливается в "Disabled".

В других версиях BIOS опция может называться "PWR Up On Modem Act" или "Ring Resume From Soft Off".

Использование этих опций возможно при использовании внешнего модема, естественно включенного в то время, как система находится в "спящем" состоянии.

Ссылки

BIOS

28 июля 2001 года


SDRAM Configuration

Конфигурация SDRAM-памяти. Установкой параметров опции определяется, должен ли BIOS определять временные характеристики доступа к памяти на основании информации из SPD-модуля ("By SPD") или же пользователь проведет конфигурирование доступа самостоятельно (через установку "Disabled").

Нетрудно увидеть схожесть данной опции с "Auto Configuration". В качестве фиксированных значений могут быть предложены параметры: "7 ns (143 Mhz)" и "8 ns (125 Mhz)" как для памяти с временем доступа 7 нс/8 нс и соответственно частотой шины 143 МГц/125 МГц.

Ссылки

BIOS

26 июля 2001 года


SDRAM Banks Close Policy

Правила закрытия банков SDRAM памяти. Параметр был введен для плат с набором 440LX из-за того, что память с 2-х банковой организацией некорректно работает в этих платах, если параметры доступа к банкам памяти установлены по умолчанию. В наборе 430TX этого не требовалось, так правила доступа для различной памяти были одинаковы. Изменять установки BIOS по умолчанию для этого параметра следует только в случае нестабильной работы памяти. Может принимать значения:

  • Page Miss - используется для двухбанковой памяти
  • Arbitration - для памяти из 4-х банков

Ссылки

BIOS

28 июля 2001 года


SDRAM (CAS Lat/RAS-to-CAS )

Cинхронная память - задержка CAS/от-RAS-к-CAS. Этот параметр позволяет комбинировать между длительностью сигнала CAS и задержкой между сигналами RAS и CAS. Значение этого параметра зависит от характеристик SDRAM, примененной в материнской плате и от быстродействия процессора. Поэтому изменять этот параметр стоит крайне осторожно. Может принимать значения:

  • 2/2
  • 3/3

Ссылки

BIOS

28 июля 2001 года


SDRAM CAS# Latency

Задержка CAS для SDRAM. Устанавливает значение задержки выдачи сигнала CAS для SDRAM. Меньшее значение увеличивает производительность системы. Рекомендуется устанавливать меньшее значение для SDRAM с быстродействием 10 ns или лучше. Может принимать значения:

  • 2T
  • 3T

Ссылки

BIOS

28 июля 2001 года


SDRAM CAS to RAS Delay

Задержка между CAS и RAS. Параметр определяет значение задержки после выдачи сигнала RAS до появления сигнала CAS для синхронной памяти. Чем меньше это значение, тем быстрее доступ к памяти. Тем не менее изменять его следует осторожно. Параметр может принимать значения:

  • 3 - три такта задержки
  • 2 - два такта задержки

Ссылки

BIOS

28 июля 2001 года


SDRAM RAS Precharge Time

Cинхронная память - время предварительного заряда. Параметр позволяет определять быстрое или медленное накопление заряда по RAS до начала цикла регенерации памяти. Установка значения Fast увеличивает быстродействие, но Slow повышает стабильность работы компьютера, поэтому значение Fast следует устанавливать в случае уверенности в качестве памяти. Может принимать значения:

  • Fast - быстро
  • Slow - медленно

Ссылки

BIOS

28 июля 2001 года


Speculative Leadoff

Опережающая выдача сигнала чтения. Разрешение этого параметра позволяет выдавать сигнал чтения немного ранее, чем адрес будет декодирован. Этот прием снижает общие затраты времени на операцию чтения. Другими словами, процессор будет инициировать сигнал чтения одновременно с генерацией того адреса, где находятся необходимые данные. Сигнал чтения воспринимается контроллером DRAM и, если параметр Speculative Leadoff разрешен, то контроллер выдаст сигнал чтения до завершения декодирования адреса. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

28 июля 2001 года


Standby Mode

Режим ожидания работы. Устанавливает время перехода или запрещает переход во вторую стадию снижения энергопотребления. Может принимать значения:

  • 30 Sec
  • 1 Min
  • 2 Min
  • 4 Min
  • 8 Min
  • 20 Min
  • 30 Min
  • 40 Min
  • 1 Hour
  • Disabled

Ссылки

BIOS

3 сентября 2001 года


Stby Speed

Частота процессора в режиме Standby. Определяет коэффициент деления тактовой частоты в режиме Standby (ожидания работы).

Ссылки

BIOS

3 сентября 2001 года


Suspend Mode

Режим временной остановки. Устанавливает время перехода или запрещает переход в третью стадию снижения энергопотребления. Может принимать значения:

  • 30 Sec
  • 1 Min
  • 2 Min
  • 4 Min
  • 8 Min
  • 20 Min
  • 30 Min
  • 40 Min
  • 1 Hour
  • Disabled
  • Disabled

Ссылки

BIOS

3 сентября 2001 года


Suspend Switch

Переключатель режима Suspend. Параметр разрешает или запрещает переход в режим suspend (временной остановки) с помощью кнопки на системном блоке. Для этого необходимо соединить джампер SMI на материнской плате с кнопкой на лицевой панели. Как правило, для этого используется либо специальная кнопка Sleep, либо кнопка Turbo. Режим suspend является режимом максимального снижения энергопотребления компьютером. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

3 сентября 2001 года


SE

Single-Ended - технология устройств, передачи данных, разъемов, в которой используются однополярные сигналы в уровнях TTL-логики, что характерно для Ultra Wide SCSI. Внутренние ограничения SCSI-стандартов были в значительной степени преодолены в интерфейсе Ultra2 Wide SCSI, обеспечившем скорость передачи до 80 МБ/с.

Постоянное развитие SCSI-интерфейсов ставило целью повышение частоты, что приводило в итоге к ограничению максимальной длины интерфейсного кабеля. Технология LVD работает, в отличие от SE, с двухполярными сигналами низкого уровня. Каждый сигнал шины Ultra2 Wide передается по двум проводам в противофазе (дифференциально). Это - так называемая низковольтная дифференциальная передача сигналов, или Low Voltage Differential (LVD). Благодаря ей удалось увеличить допустимую длину соединительного кабеля до 12 м.

Ссылки

BIOS

28 июля 2001 года


SYMBIOS (NCR) SCSI BIOS

Параметр устанавливает разрешение на поиск SCSI-контроллера на базе микросхемы NCR 810, используемой, например, в карте "ASUS SC-200". Параметр может принимать значения:

  • "AUTO" - разрешен автоматический поиск SCSI-контроллера и запуск BIOS для него
  • "Disabled" (запрещено) - устанавливается в это значение при отсутствии SCSI-карты

Ссылки

BIOS

28 июля 2001 года


Security Option

Опция, позволяющая ограничить доступ к системе и к "BIOS Setup", или только к "BIOS Setup". Выбор "System" блокирует загрузку компьютера и доступ к "BIOS Setup". Вход в систему тогда возможен только при вводе правильного пароля. Выбор "Setup" не ведет к блокировке загрузки ПК, но блокирует вход в "BIOS Setup". По умолчанию - "Setup".

Ссылки

BIOS

28 июля 2001 года


Single ALE Enable

Разpешение одиночного сигнала ALE. Немножко информации. Пин B28 на шине ISA - это сигнал BALE (Bus Adress Latch Enable - разрешение защелкивания адреса). Это сигнал стробирования адресных разрядов. Может использоваться устройствами ввода/вывода для заблаговременной подготовки к предстоящему обмену информацией. Эта линия становится активной всякий pаз пpи появлении на шине адpеса. Стоит добавить, что этот сигнал использовался еще во времена 808x-х процессоров. Сигнал этот используется редко.

Устанавливая "Enabled", активизируем одиночный сигнал ALE вместо множественных сигналов-стробов во время ISA-циклов. В какой-то степени выбор параметра был привязан и к скорости системной шины, т.е. пропускной способности системы. Поэтому установка в "Enabled" могла привести к замедлению быстpодействия видеоканала.

Эта функция всегда оставалась достаточно "темной" функцией "BIOS Setup". "Disabled" рекомендовано.

Опция может называться также "ALE During Bus Conversion" с возможными вариантами выбора:

  • "Single" (одиночный)
  • "Multiple" (множественный)

Естественно, что при потоковой работе ISA-шины (т.е. множественных циклов чтения/записи) предпочтительнее была бы установка опции в "Multiple". Но какой правильный выбор должен был сделать пользователь, всегда оставалось загадкой.

Некоторые чипсеты имели поддержку усовершенствованного режима, при котором выдача множественных сигналов ALE производилась во время одиночных циклов шины. Функция BIOS при этом называлась "Extended ALE", а параметрами служили "Disabled" и "Enabled".

В наиболее "древних" версиях BIOS весь смысл сказанного выше был заключен в опции под названием "Quick Mode".

Ссылки

BIOS

12 июля 2001 года


Slow Refresh (1:4)

Медленная pегенеpация. При включении этой опции схема регенерации будет в 4 раза реже регенерировать память (64 мкс против 16), чем в обычном pежиме. При такой установке пpоизводительность системы повышается благодаpя уменьшению конкуpенции между CPU и схемой pегенеpации, однако не все типы динамических ОЗУ могут поддеpживать такие циклы (в этом случае будет получено сообщение об ошибке четности и о сбое системы). Тогда необходимо установить значение "Disabled".

Опция в свое время получила распространение с развитием такого типа ПК, как "laptop" (дорожный ПК), в качестве энергосберегающей функции. В современных системах эта опция встречается все реже.

Опция может называться также "DRAM Slow Refresh", "Slow Refresh", "Slow Memory Refresh Divider" или "Slow Refresh Enable".

Ссылки

BIOS

26 июля 2001 года


Snoop Ahead

Предвидение. Эта опция применима, если в системе включено кэширование. Когда опция установлена в "Enabled", "master"- устройства на PCI-шине могут контролировать регистры VGA-палитры для непосредственных циклов записи и преобразования их в потоковый протокол PCI-формата с целью повышения скоростных характеристик обмена данными между PCI-шиной и памятью. В итоге значительно увеличивается производительность системы в процессе передачи видеоданных.

Ссылки

BIOS

26 июля 2001 года


Spread Spectrum Modulated

Hаспространение модулированного спектра. При работе тактового генератора может возникать такое явление, как электромагнитная интерференция (ElectroMagnetic Interference - EMI). Физически интерференция есть не что иное, как взаимодействие (наложение) двух или более волновых колебаний. В их появлении, сопровождающемся характерными для таких процессов многочисленными частотными гармоническими составляющими, "виноваты" экстремальные значения (пики) генерируемых тактовых импульсов. Включение опции позволяет сгладить пики и уменьшить интерференцию.

На решение этой задачи направлен целый комплекс средств, следящий за работой тактового генератора и качеством вырабатываемых им сигналов.

Уменьшение электромагнитного излучения, кроме чисто технических задач, затрагивает и экологические проблемы, оно может достигать 6%. Следует заметить, что это может отрицательно отразиться на работе чувствительных к форме сигнала устройств, например, жестких дисков с интерфейсом Fast Wide SCSI. Поэтому параметр рекомендуется разрешать только при испытаниях компьютеров на электромагнитную совместимость.

Кроме того, есть еще режим "Smart Clock". В этом режиме тактовые сигналы шин AGP, PCI и SDRAM отключаются в момент, когда не требуется их использование. В таком случае включение опции не сказывается на стабильности работы. Может принимать значения:

  • Enabled
  • Disabled
  • 0.25%
  • 0.5%
  • Smart Clock

Ссылки

BIOS

28 июля 2001 года


Stop CPU at PCI Master

Когда опция включена ("Enabled"), работа центрального процессора может быть приостановлена в момент инициирования PCI-устройством захвата шины. Установка в "Disabled" (по умолчанию) не позволяет прерывать работу CPU как задатчика шины. Для прерывания тогда может потребоваться использование дополнительных функций "BIOS Setup".

Ссылки

BIOS

26 июля 2001 года


Swap Floppy Drive

Перестановка дисководов. Опция, позволяющая "поменять местами" дисководы A: и B: и сделать загрузочным дисковод B: (или наоборот). Опция имеет смысл только при наличии двух дисководов в компьютере и необходимости сделать загрузочным дисковод 5.25". При этом дисководы меняются местами только логически, а не физически. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено (по умолчанию)

Ссылки

BIOS

26 июля 2001 года


System Thermal

Установка режима наблюдения за системной температурой. Выбор вариантов для данной функции невелик. Установка "Ignore" блокирует возможность перевода центрального процессора на безопасный режим работы. Параметр "Monitor" позволяет системе отслеживать возможность появления опасной ситуации.

В данном случае речь идет о достижении CPU критической температуры, устанавливаемой в поле "CPU Critical Temperature". При достижении центральным процессором этой температуры внутренняя частота процессора снижается до величины, устанавливаемой в процентах в поле "Thermal Slow Clock Ratio".

Ссылки

BIOS

28 июля 2001 года


Thermal Slow Clock Ratio

"50-62.5%" - один из вариантов.

Ссылки

BIOS

28 июля 2001 года


Trigger Method

Опция, позволяющая оптимизировать установку IRQ для PCI-слотов и могущая принимать значения "Auto" или "Forced". Для PCI- карты необходимо установить значение "Auto". Эта установка проверяет, нуждается ли PCI-карта в IRQ. Если карта не нуждается в IRQ, то система оставляет его для других ресурсов. Установка "Forced" используется в том случае, если BIOS автоматически не определяет, нуждается ли PCI-карта в прерываниях. Если установлено значение "Forced", то выделенный IRQ может использовать только данная PCI-карта.

Примечание! Если используемый в системе SCSI-контроллер с NCR-чипом не работает, то для этого контроллера необходимо установить прерывание IRQ15 и опцию "Level Trigger".

Ссылки

BIOS

29 июля 2001 года


Turn-Around Insertion

Задержка между циклами. Если этот параметр разрешен (Enabled), то между двумя последовательными циклами обращения к памяти включается один дополнительный такт. Разрешение уменьшает быстродействие, но увеличивает достоверность при операциях чтения/записи. Может принимать значения:

  • Enabled - разрешено
  • Disabled - запрещено

Ссылки

BIOS

28 июля 2001 года


Typematic (Rate) Delay (Msec)

Задержка повторения в мсек. Эта опция регулирует вторую временную характеристику - задержку перед автоповтором нажатой клавиши, которая может меняться от 0,25 до 1 сек., т.е. значение задержки от момента нажатия клавиши до начала повторения символа клавиатурой. Значение может быть выбрано из ряда:

  • 250 мсек
  • 500 мсек
  • 750 мсек
  • 1000 мсек

Опция также функционирует только при включенном состоянии опции "Typematic Rate Setting".

Ссылки

BIOS

26 июля 2001 года


Keyboard Reset Control

Эта опция позволяет регулировать скорость ввода символов с клавиатуры, но только при включенном состоянии опции "Typematic Rate Setting". С ее помощью устанавливается временная характеристика - количество сигналов повторения нажатой и не отпущенной клавиши за цикл, которое может изменяться от 6 до 30 символов в секунду, т.е. задается частота автоматического повторения символов клавиатуры. Установка большего значения позволяла, например, при работе с "MS-DOS" ускорить передвижение курсора.

Ссылки

BIOS

28 октября 2000 года


UART2 Mode Select

Наличие такой опции в "BIOS Setup" означает, что системная плата поддерживает IrDA-функцию. Если используется последовательный порт COM2, то это поле нужно установить в "Normal". В остальных случаях эта опция служит для установки типа, или можно сказать, спецификаций IrDA-стандарта, поддерживаемого IrDA-периферийным устройством.

Правда, значение "Standard" в разных версиях BIOS может обозначать и стандартный RS-232C-интерфейс, и поддержку последовательного инфракрасного интерфейса. При активировании IrDA-функции становятся доступными пользователю опции "RxD, TxD Active" и "IR Transmission Delay". Приводим почти все множество возможных вариантов используемых значений:

  • "Normal"
  • "Standard" - см. выше
  • "IrDA 1.0" - инфракрасный интерфейс, совместимый со спецификацией 1.0
  • "IrDA SIR" или "SIR" - просто IrDA-совместимый serial infrared порт
  • "IrDA MIR" или "MIR" - инфракрасный порт со скоростью в 1 Мб/сек.
  • "MIR 0.57M" - инфракрасный порт со скоростью в 0,57 Мб/сек.
  • "MIR 1.15M" - инфракрасный порт со скоростью в 1,15 Мб/сек.
  • "IrDA FIR" или "FIR" - просто fast infrared порт
  • "Sharp IR" - стандарт передачи со скоростью до 4 Мб/сек.
  • "HPSIR" - поддержка инфракрасного интерфейса с форматом фирмы "Hewlett-Packard"
  • "ASKIR" - Amplitude Shift Keyed Infrared port
  • "Disabled"

В некоторых вариантах аналогичная функция может называться "UART 2 Mode", "Onboard UART 2 Mode", "Infra Red Function", "IR Mode Select", "UR2 Mode", "Onboard IR Function" или "IR Function".

Ссылки

BIOS

26 июля 2001 года


USB IRQ

Прерывание шины USB. Параметр разрешает/запрещает назначение прерывания для контроллера шины USB. Поскольку в системе может не хватать свободного прерывания, разрешать этот параметр следует только при наличии устройства на шине USB. Также были замечены конфликты при одновременном использовании USB-устройств и звуковых карт на чипах "Aureal", и это было связано с распределением прерываний. Так что требуется внимательность. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Опция может носить название "Assign IRQ For USB" или "Use An IRQ for USB". Для последней опции параметрами были "No" и "Yes".

Ссылки

BIOS

29 июля 2001 года


USB Keyboard Support Viae

Описание настроек BIOS Setup

USB Keyboard Support Via

Метод поддержки USB-клавиатуры. Таких методов два: либо поддержка USB-клавиатуры операционной системой на уровне драйверов, либо аппаратное определение через BIOS. Если есть необходимость работы в системе, не поддерживающей USB-шину, то необходимо включить поддержку через BIOS. Может принимать значения:

  • "OS" - речь идет, например, о "Windows 98"
  • "BIOS" - такая установка необходима для той же "MS-DOS"

Ссылки

BIOS

26 июля 2001 года


VGA 128k Range Attribute

Во включенном состоянии ("Enabled") к адресам VGA-памяти (A0000H-BFFFFH) чипсетом могут быть применены свойства, подобные функциям "CPU-TO-PCI Byte Merge" или "CPU-TO-PCI Prefetch", т.е. стандартным режимам буферизации записи от CPU в PCI- интерфейс. Это повышает быстродействие системы, в противном случае используется стандартный VGA-интерфейс.

Этот же смысл характерен для множества функций с непохожими наименованиями: "VGA Performance Mode", "Turbo VGA (0 WS at A/B)", "VGA Frame Buffer", хотя в некоторых случаях "оперативный" диапазон сужается до первых 64 кБ (A0000-B0000).

Дополнительная информация о видеофункциях содержится в опциях: PCI - "Snoop Ahead".

Ссылки

BIOS

26 июля 2001 года


Video

Установка типа видеоадаптера для первичного системного монитора. Хотя вторичный монитор поддерживается и некоторыми ОС, установки в "BIOS Setup" для него отсутствуют. По умолчанию устанавливается "EGA/VGA". Возможны варианты:

  • "Mono" (Monochrome) - для монохромных видеоадаптеров
  • "Hercules" - также для монохромных видеоадаптеров
  • "MDA" - для монохромных видеоадаптеров, поддерживающих только текст
  • "CGA 80" (Color Graphics Adapter) - для режима 80 колонок
  • "CGA 40" (Color Graphics Adapter) - для режима 40 колонок
  • "EGA/VGA" (Enhanced Graphics Adapter/Video Graphics Array) - для EGA-, VGA-, SVGA- и PGA-адаптеров мониторов. Последний параметр может называться и "VGA/PGA/EGA"

Опция может иметь название и "Primary Display", а для выбора значений могут быть предложены "Absent" и "VGA, EGA". Вариант с отсутствующим дисплеем также может найти применение, как ни странно, например, в специализированных технологических системах. Во всяком случае, автор с такой ситуацией сталкивался.

Необходимо вспомнить и о применении жидкокристаллических дисплеев. Опция может называться "LCD&CRT", а значения параметра могут быть следующие:

  • "LCD" (Liquid Crystal Display) - жидкокристаллический дисплей
  • "CRT" (Cathode Ray Tube) - дисплей с электронно-лучевой трубкой
  • "AUTO" - автоматическое определение устройства
  • "LCD&CRT" - объединенный параметр

Ссылки

BIOS

11 июля 2001 года


Video BIOS Cacheable

Кэширование области BIOS видекарты. Разрешение этого параметра приводит к возможности кэширования области памяти по адресам BIOS видеокарты (C0000H-C7FFFH) в кэш-память процессора. Параметр будет использован только при включении кэш-памяти в разделе "BIOS Features Setup". Если какая-либо программа попытается выполнить запись в эти адреса, то система выдаст сообщение об ошибке.

Пpи наличии видеокаpты с "ускоpителем" необходимо отключить кэширование видеопамяти, дабы центральный процессор мог "отслеживать" любые изменения, пpоизводимые устpойством ввода в буфеp кадpа изобpажения. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Об оправданности включения этой опции можно сказать то же самое, что и по системному BIOS. Опция может называться "Video BIOS Area Cacheable".

Ссылки

BIOS

12 июля 2001 года


Video Memory Cache Mode

Режим кэширования для видеопамяти. Параметр действителен только для процессоров архитектуры Pentium Pro (Pentium II, Deshutes и т.п.). В процессоре Pentium Pro была предусмотрена возможность изменять режим кэширования в зависимости от конкретной области памяти через специальные внутренние регистры, называемые Memory Type Range Registers - MTRR.

С помощью этих регистров для конкретной области памяти могут быть установлены режимы UC (uncached - не кэшируется), WC (write combining - объединенная запись), WP (write protect - защита от записи), WT (write through - сквозная запись) и WB (write back - обратная запись).

Установка режима USWC (uncached, speculative write combining - не кэшировать, режим объединенной записи) позволяет значительно ускорить вывод данных через шину PCI на видеокарту (до 90 MB/c вместо 8 MB/c). Следует учесть, что видеокарта должна поддерживать доступ к своей памяти в диапазоне от A0000 - BFFFF (128 kB) и иметь линейный буфер кадра. Поэтому лучше установить режим USWC, но в случае возникновения каких-либо проблем (система может не загрузиться) установить значение по умолчанию UC. Может принимать значения:

  • UC (uncached) - не кэшируется
  • USWC (uncached, speculative write combining) - не кэшировать, режим объединенной записи.

Ссылки

BIOS

3 сентября 2001 года


Video Off Method

Метод выключения монитора. Устанавливается способ перехода монитора в режим пониженного энергопотребления. Может принимать значения:

  • "Blank Screen" - система очищает только экран, при этом происходит запись пустых кадров в видеобуфер. Видеокарта же работает в обычном режиме, в обычном режиме работает и монитор, с потреблением полной мощности.
  • "V/H SYNC+Blank" - параметр устанавливается по умолчанию и выбирается, если в системе имеется монитор с функциями PM. В добавление к очищенному экрану система отключит вертикальный и горизонтальный синхронизирующие сигналы, идущие от видеокарты.
  • "DPMS Supported" - использование этой опции возможно, если видеоподсистема поддерживает стандарт DPMS. DPMS (Display Power Management Signaling) - стандарт VESA, реализуемый с помощью программных функций операционной системы.

Ссылки

BIOS

28 июля 2001 года


Video Off Option

Установка режима погашения монитора. Опция позволяет установить, при каком режиме энергосбережения на мониторе будет "погашен" экран. Может принимать значения:

  • "Always On" (всегда включен) - монитор никогда не будет погашен, даже если система будет находиться в одном из режимов
  • "Suspend - Off" (погашение при включении режима "Suspend")
  • "Susp, Stby - Off" (погашение при включении одного из режимов, "Suspend" или "Standby")
  • "All modes - Off" (погашение во всех режимах)

Опция может также называться "Video Off After".

Ссылки

BIOS

28 июля 2001 года


Virus Warning

Предупреждение о вирусе. Разрешение этого параметра ("Enabled") запрещает любую запись в загрузочный сектор жесткого диска или таблицу разделов (partition table). При попытке изменения этих областей BIOS останавливает систему с выводом на экран монитора соответствующего сообщения, а также звукового сигнала. При этом пользователь может либо pазpешить запись, либо запpетить ее.

Технически эта задача решается следующим образом.

На этапе проведения POST-теста перед входом в процедуру обработки дискового сервиса (INT13h) устанавливается транзитный программный модуль, который анализирует входные параметры функции и детектирует две ситуации: попытку записи в BOOT Sector и попытку форматирования 0-й дорожки. Если система условий выполняется, вместо дисковой операции выдается предупреждающее сообщение и звуковой сигнал. На соответствующем шаге теста выполняется перестановка вектора INT13h на транзитный контролирующий модуль, если в "BIOS Setup" включен данный режим. Данный алгоритм, в зависимости от прошивок, может видоизменяться, но суть останется прежней. Подобным образом BIOS отслеживает ситуацию и при работе операционной системы.

Опция введена для защиты от так называемых boot-вирусов, поражающих загрузочный сектор. Стандартные действия при этом - запуск антивирусных программ, прежде всего с защищенных дискет.

Эта опция должна быть обязательно отключена при форматировании жесткого диска, при вводе команды FDISK/MBR, при инсталляции операционных систем, при использовании администpатоpа начальной загpузки OS/2 (OS/2 Boot Manager), котоpый использует запись в загрузочный сектоp. Кроме того, некоторые диагностические программы при обращении к boot-сектору могут вызвать появление сообщения о "вирусной атаке", что не отражает текущую ситуацию. Применение этой функции не имеет смысла в случае использования SCSI- и ESDI-дисков, поскольку они используют собственный BIOS на контpоллеpе.

Еще одним из возможных вариантов параметра может быть значение "ChipAway", с одной стороны это значение - аналог "Enabled", с другой - это один из варинтов встроенного антивируса. При старте машины выводится надпись "ChipAway Virus Enabled", что не должно пугать пользователя.

Опция может называться также "Virus Protection", "BootSector Virus Protection".

Ссылки

BIOS

26 июля 2001 года


Wait for F1 If Any Error

Если опция включена, BIOS будет ожидать нажатия клавиши "F1" для продолжения загрузки в случае какой-либо неисправности на стадии тестирования POST, но только в случае нефатальной ошибки. Если установлено в "Disabled", система выводит пpедупреждение и пpодолжает загpузку без ожидания нажатия клавиши. Рекомендуется устанавливать в "Enabled". "Disabled" может быть рекомендовано для серверных систем.

Ссылки

BIOS

11 июля 2001 года


Wake On LAN

Пробуждение от сети. При разрешении этого параметра компьютер включается по сигналу от локальной сети. Такое включение возможно только при установке в компьютер сетевой карты, поддерживающей удаленное "пробуждение".

Стоит напомнить, что если система находится в режиме "Suspend", то она пробуждается только через активизацию IRQ или DMA. Может принимать значения:

  • "Enabled" - разрешено
  • "Disabled" - запрещено

Опция может также называться "Resume On LAN".

Ссылки

BIOS

28 июля 2001 года


Weitek Coprocessor

Cопpоцессоp Weitek. Если он имеется в системе, следует установить "Enabled". Интересно, что производительность этого сопроцессора в 2-3 раза превышала производительность стандартных интеловских. Сопроцессор Weitek использует (скорее, использовал) некотоpую часть системного ОЗУ, поэтому память из этой области должна была быть отобpажена где-нибудь в дpугих адpесах. Одна из "древних" опций "AMI BIOS".

Ссылки

BIOS

26 июля 2001 года


x IR Transmission Delay

При выборе "Enabled" устанавливается режим медленной передачи данных, что может быть рекомендовано при появлении ошибок. Установка в "Disabled" снимает ограничения (задержки) на скоростные характеристики интерфейса.

Ссылки

BIOS

26 июля 2001 года


x KB Power On Hot Key

При выборе значения "Hot Key" активируется поле "KB Power On Hot Key". Пользователю предлагается на выбор один из вариантов для запуска системы с помощью "горячих клавиш" из ряда: "Ctrl-F1" - "Ctrl-F12".

А с "Keyboard 98" объяснение следующее. Это значение будет работать, если ПК укомплектован "Windows 98"-совместимой клавиатурой, на которой есть клавиша "Wake Up" (или просто "Wake"). Тогда для пробуждения системы будет использоваться только эта клавиша.

Ссылки

BIOS

28 июля 2001 года


x KB Power On Password

Когда в базовой опции выбрано значение "Password", активным становится поле "KB Power On Password". За нажатием клавиши "ENTER" следует ввод пароля. При выходе из режима Suspend необходимо ввести корректный пароль, иначе не спасет и кнопка включения питания.

Ссылки

BIOS

28 июля 2001 года


x RxD, TxD Active

Опция установки полярности сигналов приема/передачи инфракрасного интерфейса. Стоит упомянуть, что "RxD" означает receiver (приемник), а "TxD" - transmitter (передатчик). Для установки параметра необходимо из документации выяснить, в каком режиме должны работать эти сигналы приемо/передатчика.

В качестве значений используются комбинации параметров "High" и "Low". Опция может принимать значения:

  • "Hi,Lo"
  • "Lo,Hi"
  • "Lo,Lo"
  • "Hi,Hi"

Опция может носить название "Use IR Pins", а возможными значениями параметра могут быть "IR-RX2TX2" (по умолчанию) и "IR-RXTX".

Ссылки

BIOS

26 июля 2001 года


Errors

В процессе старта системы и проведения POST-теста возможны различного рода аппаратные ошибки, сопровождаемые параллельным выводом на экран монитора соответствующих сообщений. Некоторые из приведенных ниже сообщений несколько утратили свою актуальность, некоторые просто отсутствуют. Умышленно выведены, например, из этого перечня сообщения об ошибках с EISA-шиной. В остальном, этот материал будет несомненно полезен.

Ссылки

BIOS

26 июля 2001 года


FDD Controller Failure

Ошибка связи с контроллером гибких дисков. Проверить подсоединение дисковода и его разрешенность на мультикарте (для устаревших систем).

Ссылки

BIOS

26 июля 2001 года


8042 Gate-A20 Error!

Линия A20 контроллера клавиатуры (8042) не работает. Заменить контроллер клавиатуры.

Ссылки

BIOS

26 июля 2001 года


Floppy disk(s) fail

Нельзя найти или инициализировать контроллер или сам флоппи-дисковод.

Ссылки

BIOS

26 июля 2001 года


Hard Disk(s) fail (20)

Ошибка инициализации жесткого диска.

Ссылки

BIOS

26 июля 2001 года


Hard Disk(s) fail (40)

Ошибка инициализации жесткого диска.

Ссылки

BIOS

26 июля 2001 года


Hard disk(s) diagnosis fail

Ошибка начальной диагностики жесткого диска.

Ссылки

BIOS

26 июля 2001 года


HARD DISK INSTALL FAILURE

Нельзя найти или инициализировать контроллер или сам жесткий диск. Действия те же, т.е. проверить все механические установки и подключения, а также правильность установок в "BIOS Setup".

Ссылки

BIOS

26 июля 2001 года


FLOPPY DISK CNTRLR ERROR OR NO CNTRLR PRESENT

Невозможно инициализировать контроллер гибких дисков. Проверить установку контроллера и параметры дисковода, указанные в "BIOS Setup".

Ссылки

BIOS

26 июля 2001 года


ERROR ENCOUNTERED INITIALIZING HARD DRIVE

Не инициализируется жесткий диск. Проверить установку контроллера жестких дисков (для устаревших систем), соединительные кабеля, а также параметры "BIOS Setup".

Ссылки

BIOS

26 июля 2001 года


ERROR INITIALIZING HARD DRIVE CONTROLLER, HDD Controller Failure

Ошибка связи с контроллером жестких дисков, контроллер жестких дисков не инициализируется. Проверить установку контроллера, подсоединение дисковода и параметры жесткого диска в "BIOS Setup". Также стоит проверить установку джамперов на жестком диске.

Ссылки

BIOS

26 июля 2001 года


Diskette Boot Failure

Дискета в дисководе А: не является загрузочной, т.е. невозможно загрузиться с дискеты в процессе запуска ПК. Дискета может не быть загрузочной, либо системные файлы повреждены.

Ссылки

BIOS

26 июля 2001 года


DMA #1 Error, DMA #2 Error

Ошибка первого/второго канала DMA. Ошибка может быть вызвана соответствующим периферийным устройством.

Ссылки

BIOS

26 июля 2001 года


DMA Bus Time-out

Устройство не отвечает в течении 7,8 мкс. Проблема в платах расширения. Необходимо найти плату, которая вызывает эту ошибку и заменить ее.

Ссылки

BIOS

26 июля 2001 года


DMA Error

Ошибка контроллера DMA. Возможна замена материнской платы.

Ссылки

BIOS

26 июля 2001 года


DISKETTE DRIVES OR TYPES MISMATCH ERROR - RUN SETUP

Типы дисководов, фактически установленных в системе, и их описания в CMOS не сходятся. Необходимо запустить "BIOS SETUP" и ввести правильные типы дисководов.

Ссылки

BIOS

26 июля 2001 года


DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

Не найден загрузочный диск. Необходимо загрузиться с дискеты и проверить системные файлы на жестком диске.

Ссылки

BIOS

26 июля 2001 года


DISPLAY SWITCH IS SET INCORRECTLY, Display Switch Not Proper

Неправильно выставлен тип монитора (монохромный или цветной). Переставить соответствующий джампер на материнской плате в правильное положение или исправить выбор типа монитора в "BIOS Setup".

Ссылки

BIOS

26 июля 2001 года


DISPLAY TYPE HAS CHANGED SINCE LAST BOOT

Изменился тип дисплея со времени последней загрузки. В "BIOS Setup" ввести правильный тип дисплея.

Ссылки

BIOS

26 июля 2001 года


Cache Memory Bad, Do Not Enable Cache!

Ошибка кэш-памяти. Возможно потребуется замена. Хотя сначала стоит попробовать просто перезагрузиться.

Ссылки

BIOS

26 июля 2001 года


CH-2 Timer Error

Ошибка второго таймера. Некоторые системы имеют два таймера.

Ссылки

BIOS

26 июля 2001 года


CMOS Checksum Error, CMOS Checksum Failure

Неправильная контрольная сумма CMOS, что свидетельствует о повреждении данных в CMOS, возможно из-за сбоя батареи. Если попытка восстановления "BIOS Setup" окажется неудачной, возможно придется обращаться в сервисный центр со своей материнской платой.

Ссылки

BIOS

26 июля 2001 года


CMOS Memory Size Mismatch

Объем физической памяти на материнской плате не сходится с тем, что зафиксировалось в CMOS RAM. Необходимо перезапустить "BIOS Setup", проверить все установки. После перезагрузки ПК ошибка может исчезнуть, иначе потребуется замена компонентов материнской платы.

Ссылки

BIOS

26 июля 2001 года


CMOS System Options Not Set

Данные в CMOS повреждены или отсутствуют. Действия пользователя аналогичны вышеприведенным.

Ссылки

BIOS

26 июля 2001 года


CMOS Time and Date Not Set

Нарушены или не установлены параметры даты и времени. Задача сводится к проверке или установке этих параметров в "BIOS Setup".

Ссылки

BIOS

26 июля 2001 года


CMOS battery failed, CMOS Battery Has Failed, CMOS Battery State Low

Эти сообщения в начале загрузки компьютера свидетельствуют о неисправности батареи или ее разрядке. Необходимо заменить батарею.

Ссылки

BIOS

26 июля 2001 года


BIOS ROM checksum error - System halted

Проверочная сумма при тесте ПЗУ по адресу F0000H-FFFFFH ошибочна. Возможно потребуется восстановление (перепрошивка) микросхемы с Flash BIOS.

Ссылки

BIOS

26 июля 2001 года


Address Line Short!

Проблема со схемой декодирования адреса памяти. Имеет смысл перезагрузиться, подождав секунд 30 до повторного включения. Проблема может разрешиться сама собой.

Ссылки

BIOS

26 июля 2001 года


Auto Detect DIMM/PCI Clk

Опция "AMI BIOS", аналогичная "Security Option" для "Award BIOS", с той лишь разницей, что значению "System" соответствует значение "Always", но только лишь с блокировкой загрузки системы.

Ссылки

BIOS

28 июля 2001 года